Bug 136583 - Some resources from embedded PDF files (mainly those created by Scribus) disappear when exporting to PDF
Summary: Some resources from embedded PDF files (mainly those created by Scribus) disa...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.4 all versions
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2020-09-08 19:52 UTC by dittnamn
Modified: 2021-01-31 13:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple test PDF created in Scribus (9.03 KB, application/pdf)
2020-09-08 19:53 UTC, dittnamn
Details
New test file created in Scribus (114.01 KB, application/pdf)
2020-09-15 11:35 UTC, dittnamn
Details
Exported PDF file from Libreoffice with missing resources (4.01 KB, application/pdf)
2020-09-15 11:36 UTC, dittnamn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dittnamn 2020-09-08 19:52:29 UTC
Description:
When adding a PDF file created in Scribus as a picture, the picture is shown in Libreoffice, but when you export it to a PDF file, the picture is removed and replaced with a white frame. I've tested in both Calc and Writer with the same results.

Steps to Reproduce:
1. Create a PDF file in Scribus (example file attached).
2. Insert it into a Libreoffice document as a picture.
3. Export Libreoffice document as PDF.

Actual Results:
The exported PDF doesn't contain the image from the PDF file. It's just a white frame where it should be.

Expected Results:
When adding other PDF files the same way, they can be exported.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
This probably affects files from other PDF creation tools as well, but I've noticed it with Scribus.
Comment 1 dittnamn 2020-09-08 19:53:17 UTC
Created attachment 165292 [details]
Simple test PDF created in Scribus
Comment 2 dittnamn 2020-09-15 11:34:46 UTC
I've done some more testing, and it seems like not all parts of the PDF files disappear. So far, I've noticed that it's fonts, patterns, pictures, and other PDF files embedded in the PDF file.

I attach two new PDF files, converted to QDF format for easier understanding. One is created in Scribus and one is created in Libreoffice and contains the Scribus file.

The Scribus PDF file contains:
- A frame with a pattern
- An image
- A text frame saying "TEST", connected to a subsetted font
- A green shape
- An image frame with the previous PDF file embedded.

What happens is that the resources needed to show some of these elements are not copied in the Libreoffice export. So, in this case the missing resources are: /Fo0, /Pattern9, /REI1 and /RE!4.
Comment 3 dittnamn 2020-09-15 11:35:40 UTC
Created attachment 165518 [details]
New test file created in Scribus
Comment 4 dittnamn 2020-09-15 11:36:24 UTC
Created attachment 165519 [details]
Exported PDF file from Libreoffice with missing resources
Comment 5 dittnamn 2020-09-16 10:17:33 UTC
For the part of the PDF patterns, it seems like it's not exclusive to PDF files from Scribus and I can't get them to work with PDF files from other tools either. This part might be related to bug #131001.

Other than that, it looks like Scribus uses more nested resources than the other PDF creators I've tried. Nothing seems to be wrong with those files, it's just that Libreoffice doesn't copy those resources.

I've tried using some old versions, and it almost works in version 5.3.7.2, except for the patterns that are rendered incorrectly.
Comment 6 Roman Kuznetsov 2021-01-31 13:37:09 UTC
confirm a dataloss in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 5346b2556348477dcec371913d5924c6badfa2c7
CPU threads: 4; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded