Bug 136592 - Backup copy ("DE: Sicherungskopie) is created without data; writing data impossible; error message box displayed (Samba related)
Summary: Backup copy ("DE: Sicherungskopie) is created without data; writing data impo...
Status: RESOLVED DUPLICATE of bug 55004
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-09 06:04 UTC by franzbing
Modified: 2020-09-09 11:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Option settings for Load/Save which seem to cause the problem (108.72 KB, image/png)
2020-09-09 11:08 UTC, franzbing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description franzbing 2020-09-09 06:04:15 UTC
Description:
Option set is "Always create backup copy" (free translation from German phrase "Sicherungskopie immer erstellen") 

Every time when saving after initial save, the error message box comes up. I know this bug from former versions of LibreOffice

Steps to Reproduce:
1. create a file eg in Writer and write some text
2. save the document
3. change one character
4. save again - the message box comes up with statement 

Actual Results:
message box with following content:
error when saving "document"
error when creating object
backup copy could not be created

Expected Results:
no message
BAK file under path set in Options
BAK file has content
BAK file size larger than zero bytes


Reproducible: Always


User Profile Reset: Yes



Additional Info:
IVersion: 6.4.5.2
Build-ID: 1:6.4.5-0ubuntu0.20.04.1
CPU-Threads: 4; BS: Linux 5.4; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded
Comment 1 Julien Nabet 2020-09-09 07:20:49 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.

Here the steps I did:
1) created a brand new file on Writer
2) Typed "test"
3) File/Save As, chose name and location
4) Typed "1" after "test"
5) Ctrl+S to Save
=> no message box.

Did I miss something?
Had you enable some specific option?
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/QA/FirstSteps#Corrupted_user_profile)?
Comment 2 franzbing 2020-09-09 11:01:35 UTC
First your questions:
Did I miss something? No.
Had you enable some specific option?  I do not know which one could be special, there are so many .
For the test, could you rename your LO directory profile?  Now I renamed the ../user to ../user (old) and started LO. Afterwards, I found a new .../user dir. The problem did NOT come back!


The system is an Ubuntu Ubuntu 20.04.1 LTS latest system actualisation.
The bug reported occured when I saved the data file on a samba share (Debian 10 Buster with latest system act.), while the option says backup path is local: /home/myname/.config/libreoffice/4/user/backup


With previous system (another Debian 10 Buster with latest system act.) the problem did not occur, but as said, I remember from former times. Maybe an Ubuntu issue?
Comment 3 franzbing 2020-09-09 11:08:28 UTC
Created attachment 165314 [details]
Option settings for Load/Save which seem to cause the problem
Comment 4 Julien Nabet 2020-09-09 11:11:22 UTC
(In reply to franzbing from comment #2)
> ...
> For the test, could you rename your LO directory profile?  Now I renamed the
> ../user to ../user (old) and started LO. Afterwards, I found a new .../user
> dir. The problem did NOT come back!
Great!

> The system is an Ubuntu Ubuntu 20.04.1 LTS latest system actualisation.
> The bug reported occured when I saved the data file on a samba share (Debian
> 10 Buster with latest system act.), while the option says backup path is
> local: /home/myname/.config/libreoffice/4/user/backup
Samba part may be the root cause. I mean I suppose LO doesn't deal well with share networks sometimes.

Did you try again to reproduce this with a brand new file and saving on Samba? (if possible the same network share you used)?
Comment 5 franzbing 2020-09-09 11:11:54 UTC
When de-selecting "Sicherungskopie immer erstellen/Always create backup copy" the save action runs fine.
When selecting "Sicherung..." even with no restart of LO, the error message pops up immidiately.

When the file is saved locally, there is no issue.
Seems there is an issue with save path pointing to a samba share, while backup is local.
Comment 6 franzbing 2020-09-09 11:14:06 UTC
I used the same share.
Redo of tests with new files.
Comment 7 franzbing 2020-09-09 11:15:07 UTC
Anyway, thank you for your prompt check and responses!
In case you need some test person, feel free to contact me
Comment 8 Julien Nabet 2020-09-09 11:20:47 UTC
Just to be sure, the error message is:
"Speichert die vorherige Version eines Dokuments als Sicherungskopie, wenn Sie ein Dokument speichern. Jedes Mal, wenn LibreOffice eine Sicherungskopie erstellt, wird die vorherige Sicherungskopie ersetzt. Die Sicherungskopie erhält die Erweiterung .BAK."
?

It would correspond to:
Saves the previous version of a document as a backup copy whenever you save a document. Every time LibreOffice creates a backup copy, the previous backup copy is replaced. The backup copy gets the extension .BAK.

(
extra information from translation repo
#. TtAJZ
#: cui/uiconfig/ui/optsavepage.ui:263
msgctxt "backup"
)
Comment 9 Julien Nabet 2020-09-09 11:22:27 UTC
or is it rather:
#. mfmpc
#: svtools/inc/errtxt.hrc:120
msgctxt "RID_ERRHDL"
msgid "Could not create backup copy."
msgstr "Sicherungskopie konnte nicht erstellt werden."
?
Comment 10 franzbing 2020-09-09 11:34:46 UTC
It is "Sicherungskopie konnte nicht erstellt werden."
Comment 11 Julien Nabet 2020-09-09 11:44:03 UTC
Ok then.
I don't have a solution but as a workaround you can work locally and, at the end of your work session you can copy manually the file on network share.

Since I don't have more questions, I put it back to UNCONFIRMED.
Comment 12 Julien Nabet 2020-09-09 11:46:15 UTC
Just noticed that the pb is already known.

*** This bug has been marked as a duplicate of bug 55004 ***