Download it now!
Bug 136595 - Libre Office deletes/ moves Korean characters when using Ibus-Hangul
Summary: Libre Office deletes/ moves Korean characters when using Ibus-Hangul
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK CJK-Korean
  Show dependency treegraph
 
Reported: 2020-09-09 07:25 UTC by Paul Kim
Modified: 2020-10-13 22:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
using libreoffice on openSUSE Tumbleweeds KDE Plasma 5.19 and ibus-hangul IME (513.05 KB, image/png)
2020-09-09 15:04 UTC, DaeHyun Sung
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Kim 2020-09-09 07:25:13 UTC
Description:
Using ibus and Ibus-hangul packages to type in Korean.

When I type a Korean sentence, then select a different area to type text, the last inputted letter(s) is(are) deleted.

Steps to Reproduce:
1.Install ibus and ibus-hangul
2.Type a normal sentence
3. Go to the middle of the sentence and type a few characters
4. Immediately select the end(or any other part) of the sentence.

Actual Results:
The last typed character(s) will either be deleted or move any text you input to the end(or where you selected) of the sentence.

Expected Results:
No characters should be removed or moved.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.0.0.3
Build ID: 7.0.0-1
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

A quick video demonstrating the issue.
https://youtu.be/3hKMEUU5VHo
Comment 1 Paul Kim 2020-09-09 07:26:24 UTC
Video of the issue can be seen here

https://youtu.be/3hKMEUU5VHo
Comment 2 Julien Nabet 2020-09-09 10:39:06 UTC
DaeHyun: thought you might be interested in this one since it concerns Korean issue.
Comment 3 DaeHyun Sung 2020-09-09 15:01:55 UTC
(In reply to Paul Kim from comment #1)
> Video of the issue can be seen here
> 
> https://youtu.be/3hKMEUU5VHo

I checked the Korean IME issue.

Originally, I'm usually use fcitx-hangul, so, I've changed default IME 'fcitx-hangul' to 'ibus-hangul'.

I watched the link  https://youtu.be/3hKMEUU5VHo 
That is firefix input issue on ibus-hangul, not LibreOffice issue
I don't understand the issue.

Because, I can & typing input Korean hangul text on ibus-hangul'.

So, I would like to know your Linux distribution and desktop environment informations (such as KDE or GNOME).

I wrote the thread on openSUSE Tumbleweeds,  KDE Plasma 5.19 and ibus-hangul.

My LibreOffice Version Information
Version: 7.1.0.0.alpha0+
Build ID: b329750d30c246b8366929390b0ffd64e5f0ff4f
CPU threads: 16; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ko-KR (ko_KR.UTF-8); UI: ko-KR
Calc: threaded
Comment 4 DaeHyun Sung 2020-09-09 15:04:35 UTC
Created attachment 165326 [details]
using libreoffice on openSUSE Tumbleweeds KDE Plasma 5.19 and ibus-hangul IME

using libreoffice on openSUSE Tumbleweeds KDE Plasma 5.19 and ibus-hangul IME 

It works, It can type Korean Hangul and english using ibus-hangul.
Comment 5 Paul Kim 2020-09-10 08:07:51 UTC
(In reply to DaeHyun Sung from comment #3)
> (In reply to Paul Kim from comment #1)
> > Video of the issue can be seen here
> > 
> > https://youtu.be/3hKMEUU5VHo
> 
> I checked the Korean IME issue.
> 
> Originally, I'm usually use fcitx-hangul, so, I've changed default IME
> 'fcitx-hangul' to 'ibus-hangul'.
> 
> I watched the link  https://youtu.be/3hKMEUU5VHo 
> That is firefix input issue on ibus-hangul, not LibreOffice issue
> I don't understand the issue.
> 
> Because, I can & typing input Korean hangul text on ibus-hangul'.
> 
> So, I would like to know your Linux distribution and desktop environment
> informations (such as KDE or GNOME).
> 
> I wrote the thread on openSUSE Tumbleweeds,  KDE Plasma 5.19 and ibus-hangul.
> 
> My LibreOffice Version Information
> Version: 7.1.0.0.alpha0+
> Build ID: b329750d30c246b8366929390b0ffd64e5f0ff4f
> CPU threads: 16; OS: Linux 5.8; UI render: default; VCL: gtk3
> Locale: ko-KR (ko_KR.UTF-8); UI: ko-KR
> Calc: threaded

I apologize for the late reply. This issue happens both and KDE and Gnome. I'll make sure to report this issue to the Ibus devs as well.
Comment 6 Paul Kim 2020-09-10 08:11:08 UTC
(In reply to DaeHyun Sung from comment #4)
> Created attachment 165326 [details]
> using libreoffice on openSUSE Tumbleweeds KDE Plasma 5.19 and ibus-hangul IME
> 
> using libreoffice on openSUSE Tumbleweeds KDE Plasma 5.19 and ibus-hangul
> IME 
> 
> It works, It can type Korean Hangul and english using ibus-hangul.

The issue isn't that I cannot type in Korean but that the letters vanish or move when typing.

글자를 입력하지 못하는것이 아니라 입력하다가 마우스로 문장 다른곳을 클리하면 선택된 글자가 삭제되거나 이동하는 현상이 나타나요. 

위 댓글에 ibus 라고 하셨으니 ibus 개발자 분들에게도 알리러 갑니당.
Comment 7 QA Administrators 2020-09-10 21:35:21 UTC Comment hidden (obsolete)
Comment 8 DaeHyun Sung 2020-10-13 20:40:03 UTC
I think, the issue is an Korean IME issue, So, I change the status "NOTABUG".
Comment 9 Ming Hua 2020-10-13 20:44:59 UTC
(In reply to DaeHyun Sung from comment #8)
> I think, the issue is an Korean IME issue, So, I change the status "NOTABUG".
The proper status for bugs like this (valid bug, but about some other software, not LibreOffice) is NOTOURBUG, i.e. not our bug.
Comment 10 Paul Kim 2020-10-13 22:44:34 UTC
Are you sure?

I've beem testing this bug on other software. Firefox, Onlyoffice, Office online, Gemini etc amd can only reproduce it in Libre office.