Bug 136618 - Colunas ocultas voltam a aparecer cada vez que uma nova versão da planilha e gravada CALC
Summary: Colunas ocultas voltam a aparecer cada vez que uma nova versão da planilha e ...
Status: RESOLVED DUPLICATE of bug 128895
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-09 18:08 UTC by Jedison
Modified: 2021-07-05 15:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jedison 2020-09-09 18:08:59 UTC
Description:
As colunas não utilizadas à direita das planilhas são normalmente ocultas para maior comodidade do usuário. NO entanto, desde a versão 6.4.5 do CALC (a também na versão 7.0), cada vez que se salva uma nova versão de uma planilha, aquelas colunas voltam a ser exibidas quando se abre novamente o arquivo.
As planilhas que gravei em versões anteriores também passaram a mostrar novamente as LINHAS ocultas quando abri os arquivos na versão 6.5.4 mas, ao contrário do que acontece com as colunas, uma vez ocultadas novamente, não foram mais exibidas.

Steps to Reproduce:
1.Gravar uma planilha com todas as colunas da esquerda, a partir da coluna "G" ocultas
2.Salvar o arquivo
3.Abrir, editar e salvar de novo (nova versão) dele
4.Fechar o arquivos.
5. Voltar a abrir o arquivo da planilha.

Actual Results:
As colunas ocultas voltam a ser exibidas

Expected Results:
As colunas ocultas deveriam permanecer ocultas


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Nas versões anteriores esses problemas não ocorriam.
Comment 1 Buovjaga 2021-07-05 14:58:18 UTC
Google Translate:
Unused columns to the right of sheets are usually hidden for the user's convenience. However, since CALC version 6.4.5 (and also in version 7.0), every time a new version of a spreadsheet is saved, those columns are displayed again when the file is opened again.
Worksheets that I recorded in previous versions also started to show hidden LINES again when I opened the files in version 6.5.4 but, unlike what happens with columns, once hidden again, they were no longer shown.

Steps to Reproduce:
1.Save a spreadsheet with all columns on the left, starting from column "G" hidden
2.Save the file
3.Open, edit and save again (new version) of it
4.Close the files.
5. Reopen the spreadsheet file.

Actual Results:
Hidden columns are displayed again

Expected Results:
Hidden columns should remain hidden

Áron found an older report that sounds like this, so I will close as duplicate. Jedison: if your problem is different, we can change back to unconfirmed.

*** This bug has been marked as a duplicate of bug 128895 ***