Bug 136624 - Text on page 2 has moved to page 1 after DOCX export
Summary: Text on page 2 has moved to page 1 after DOCX export
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Paragraph
  Show dependency treegraph
 
Reported: 2020-09-09 21:14 UTC by Telesto
Modified: 2021-05-21 08:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the original document and docx version in Writer (259.83 KB, image/png)
2020-11-12 10:43 UTC, NISZ LibreOffice Team
Details
How the original .doc looks in Word 2013 and Writer (269.18 KB, image/png)
2020-11-12 10:48 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-09-09 21:14:18 UTC
Description:
Text on page 2 is missing (empty) after DOCX export

Steps to Reproduce:
1. Open the attached file
2. Save as DOCX
3. Look at page 2

Source file
https://drive.google.com/uc?id=1t1KUYvvNYs26SccTiUrnUoBmt1g_a5F4&export=download


Actual Results:
Page 2 is empty

Expected Results:
Previously "Technical Manual" would be exported. So that's what I would expect

Weighing Indicator is a much older issue. The text isn't even showing in 4.2 with ODT (co-incidence?) 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: e8b8e7be0b2ad693224cd94062a55610eb69df7e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-09-09 21:17:17 UTC
So to be clear: Technical Manual positioned on page 2 with 
Version: 6.2.0.0.alpha0+
Build ID: 9d754a59154c40235c240bb0e7f47a2006fa85bd
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL

but this not the case anymore with 
Version: 7.1.0.0.alpha0+ (x64)
Build ID: e8b8e7be0b2ad693224cd94062a55610eb69df7e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 2 NISZ LibreOffice Team 2020-11-12 10:43:32 UTC
Created attachment 167233 [details]
Screenshot of the original document and docx version in Writer

When opened the .doc file the 
Weighing Indicator
Technical Manual
paragraphs are on the second page, but saving as docx and reopening puts them to the first page. Which is, accidentally how the .doc looks in Word.

Another visual difference is that the font of these paragraphs is originally "Eurostile" which I obviously don't have, but it's replaced with a different font in the doc and docx versions, which may be another source of layout differences.

Also there are three empty pages below these and above the TOC because the original document has several section breaks (new page - 2 continous - page break) and these are incorrectly converted on .doc import. This is a problem in itself.
Comment 3 NISZ LibreOffice Team 2020-11-12 10:48:39 UTC
Created attachment 167234 [details]
How the original .doc looks in Word 2013 and Writer

This way it looks rather an import problem to begin with.
Comment 4 NISZ LibreOffice Team 2020-11-12 10:59:19 UTC
This 200 pages doc file looks quite complicated with multiple possible sources for differences. The scales image also has some differing crop values in Writer than in Word, that may or may not cause layout problems, I'm not sure.

Could you please minimize it in Word to a point where only one of the problems manifest themselves?
And possibly open multiple reports for each separate problems.
Comment 5 QA Administrators 2021-05-13 03:58:42 UTC Comment hidden (obsolete)
Comment 6 Telesto 2021-05-13 15:30:50 UTC
(In reply to NISZ LibreOffice Team from comment #4)
> This 200 pages doc file looks quite complicated with multiple possible
> sources for differences. The scales image also has some differing crop
> values in Writer than in Word, that may or may not cause layout problems,
> I'm not sure.
> 
> Could you please minimize it in Word to a point where only one of the
> problems manifest themselves?
> And possibly open multiple reports for each separate problems.

Has the NISZ by any luck a copy of the file? Obviously linking to external Google Drive account being a bad idea.... 

So not able to create some reduced file..
Comment 7 QA Administrators 2021-05-14 04:13:27 UTC Comment hidden (obsolete)
Comment 8 NISZ LibreOffice Team 2021-05-21 08:56:07 UTC
Sorry, no luck. 
Usually I don't clean up my Downloads folder, but still can't find this BX23*doc.

Let this one go. It looked like on the screenshot it has a "missing font" used for the whole document.