Bug 136668 - Fileopen generated DOCX: Blank page between regular pages because of zero-sized font
Summary: Fileopen generated DOCX: Blank page between regular pages because of zero-siz...
Status: RESOLVED DUPLICATE of bug 140182
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Section
  Show dependency treegraph
 
Reported: 2020-09-11 12:57 UTC by Zamerov Aleksandr
Modified: 2022-07-14 08:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Repro document (9.37 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-09-11 12:58 UTC, Zamerov Aleksandr
Details
Document compared (166.13 KB, image/png)
2020-09-11 14:55 UTC, Timur
Details
Repro document saved in MSO as DOC (51.50 KB, application/msword)
2022-07-14 08:16 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zamerov Aleksandr 2020-09-11 12:57:57 UTC
Description:
Document generated with FastReport2020.

In word and onlyoffice all fine, in LibreOffice6.45 and 7 versions get blank page

Steps to Reproduce:
Just open attachment

Actual Results:
2 page is blank. Actual info showed on 1 and 3 page.

Expected Results:
Only 1,3 pages showed, without blank page.


Reproducible: Always


User Profile Reset: No



Additional Info:
Maybe FastReport generate page break incorrect.
If anyone can say, how to do it correct - help me pls :)

Версия: 6.4.5.2 (x86)
ID сборки: a726b36747cf2001e06b58ad5db1aa3a9a1872d6
Потоков ЦП: 4; ОС: Windows 10.0 Build 14393; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded
Comment 1 Zamerov Aleksandr 2020-09-11 12:58:41 UTC
Created attachment 165392 [details]
Repro document
Comment 2 Timur 2020-09-11 14:55:28 UTC
Created attachment 165394 [details]
Document compared

Repro LO 7.1+. It was worse in OO.
This is older compatibility DOCX, but similar problem if resaved in MSO. 
This is a bug, but needs to be checked if a duplicate of some other report.
Comment 3 Vladimir Borisov 2020-09-15 10:45:10 UTC
Issue is caused by the following text sizes:
<w:sz w:val="0"/><w:szCs w:val="0"/>
in last paragraph with section properties.
Seems like Writer interpretes zero-sized font somehow buggy...
Can be fixed by specifying minimal values that Writer allows in UI:
<w:sz w:val="4"/><w:szCs w:val="4"/>
Comment 4 Gabor Kelemen (allotropia) 2022-07-13 22:42:57 UTC
This seems to be fixed with:

https://git.libreoffice.org/core/+/9dfaf0fa1977f70341e4b9add2ecd2afb35bf1f2

author	Attila Szűcs <szucs.attila3@nisz.hu>	Fri Feb 26 11:19:01 2021 +0100
committer	László Németh <nemeth@numbertext.org>	Sat Mar 20 14:27:42 2021 +0100

tdf#140182 DOCX table import: fix extra page break

*** This bug has been marked as a duplicate of bug 140182 ***
Comment 5 Timur 2022-07-14 08:16:40 UTC Comment hidden (obsolete)
Comment 6 Timur 2022-07-14 08:23:46 UTC Comment hidden (obsolete)
Comment 7 Timur 2022-07-14 08:25:35 UTC
I will not open DOC bug because DOC opens also in MSO with extra blank page, for this example and bug 140182.