Download it now!
Bug 136730 - table content changed after inserting column and saving document
Summary: table content changed after inserting column and saving document
Status: RESOLVED DUPLICATE of bug 131025
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Cell-Add-Delete
  Show dependency treegraph
 
Reported: 2020-09-13 22:35 UTC by Joao Carvalho
Modified: 2020-09-14 19:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Insert a column before the first column and then save, then reopen file. (13.25 KB, application/vnd.oasis.opendocument.text)
2020-09-13 22:35 UTC, Joao Carvalho
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joao Carvalho 2020-09-13 22:35:24 UTC
Created attachment 165469 [details]
Insert a column before the first column and then save, then reopen file.

If I insert a column to a table, then save the ODT document, then close, then open the same document, the contents of table are now altered.

I have attached the document that caused me problems.

Steps to reproduce:
1) Open the attached document and click on the first cell of the table.
2) Click "Table > Insert > Columns Before" to insert a column.
3) Save document and then close Writer.
4) Open document and the contents of the table are now altered.
Comment 1 Dieter 2020-09-14 06:36:40 UTC
I confirm it with

Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded
Comment 2 Timur 2020-09-14 08:36:10 UTC
Bibisect 7.0. 

commit 131b23e24d6a2731df74afa57acffe61ab1ee50c
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Feb 27 19:26:45 2020 +0100

    source sha:59ace23c367f83491a37e844d16f7d716eff6346
    previous source sha:5352d45dd4a04f8f02cf7f6ad4169126d3b3586a

https://cgit.freedesktop.org/libreoffice/core/commit/?id=59ace23c367f83491a37e844d16f7d716eff6346

author	Maxim Monastirsky <momonasmon@gmail.com>	2020-02-21 02:35:55 +0200
committer	Michael Stahl <michael.stahl@cib.de>	2020-02-27 19:04:33 +0100
commit	59ace23c367f83491a37e844d16f7d716eff6346 (patch)
tree	af47d9b808037e3af045678b60b73e47b6f1121f
parent	5352d45dd4a04f8f02cf7f6ad4169126d3b3586a (diff)
tdf#101710 Fix invalid style:data-style-name attribute

Adding Maxim to CC. Please see.
Comment 3 Maxim Monastirsky 2020-09-14 19:18:01 UTC
The bibisect is a bit misleading. The problem with a table content being replaced with "0" for cells with attached user-defined number format is a well known problem, and didn't start with my commit. See previous reports in Bug 131025 and Bug 133611. The reason bibisect pointed to my commit is likely because before that user-defined number formats of table styles were simply not imported, so when such table style was re-applied upon column insertion, it was already missing the number format, and therefore didn't show the bug.

*** This bug has been marked as a duplicate of bug 131025 ***