Bug 136765 - Settings for display formatting marks get lost after update
Summary: Settings for display formatting marks get lost after update
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formatting-Mark User-Profile-Upgrade
  Show dependency treegraph
 
Reported: 2020-09-15 09:09 UTC by Paolo Benvenuto
Modified: 2020-09-17 08:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Benvenuto 2020-09-15 09:09:57 UTC
6.0.7.3, Build ID: 1:6.0.7-0ubuntu0.18.04.10
Thread CPU: 4; SO: Linux 4.15; Resa interfaccia: predefinito; VCL: gtk3; 
Versione locale: it-IT (it_IT.UTF-8); Calc: group

Before this version (I don't know what version precisely) formatting marks were visible/invisible according to the corresponding button status.

Upgrading to this version, the visible formatting marks are resetted, the user must go to the preferences and select again what marker he/she wants to see when the button is pressed.
Comment 1 Julien Nabet 2020-09-15 11:43:23 UTC
6.0.7 is quite an old version.

You can upgrade to Ubuntu 20.04 or/and use last LO version from LO ppa https://launchpad.net/~libreoffice/+archive/ubuntu/ppa
Comment 2 Paolo Benvenuto 2020-09-15 15:34:34 UTC
The bug isn't in the app, but in the upgrade to version 6.0

The bug consist in loosing the current selection of the visible formatting marks.
Comment 3 Dieter 2020-09-15 16:05:23 UTC
Thank you for reporting the bug. It seems you're using an old version of LibreOffice. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 4 Paolo Benvenuto 2020-09-15 16:42:08 UTC
I loose the settings I explained when upgrading to 6.0.

when upgrading to 6.4 the settings where already lost.


Since the bug refers to the upgrading process, in order to see if the bug is still present an upgrade is required.

@Julien Nabet I think you aren't understanding what I'm reporting...
Comment 5 Julien Nabet 2020-09-15 17:30:32 UTC
(In reply to Paolo Benvenuto from comment #4)
> ...
> @Julien Nabet I think you aren't understanding what I'm reporting...

I suppose so, => uncc myself.
Comment 6 Dieter 2020-09-15 17:39:53 UTC
(In reply to Paolo Benvenuto from comment #0)
> Before this version (I don't know what version precisely) formatting marks
> were visible/invisible according to the corresponding button status.
> 
> Upgrading to this version, the visible formatting marks are resetted, the
> user must go to the preferences and select again what marker he/she wants to
> see when the button is pressed.

Actual and AFAIK expected behaviour is
- use VIEW => Formatting Marks to show / hide Formatting Marks (or press Strg+F10)
- select the Formatting Marks that are displayed in Tools => Options = LibreOffice Writer => Formatting Aids => Display formatting

I understand  your report in that way, that settings don't remain. Is that correct?
Comment 7 Paolo Benvenuto 2020-09-16 07:39:29 UTC
> Actual and AFAIK expected behaviour is
> - use VIEW => Formatting Marks to show / hide Formatting Marks
>   (or press Strg+F10)
> - select the Formatting Marks that are displayed in Tools => Options = 
>   LibreOffice Writer => Formatting Aids => Display formatting

That works.

The problem is that I got the Formatting Marks in "Tools => Options = LibreOffice Writer => Formatting Aids => Display formatting" reset when I upgraded libreoffice to 6.0, and I suspect that an upgrade from < 6 to any new version reset the marks too
Comment 8 Paolo Benvenuto 2020-09-16 13:52:27 UTC
Why WORKSFORME? the upgrade process does loose the selection, the bug is there!
Comment 9 Dieter 2020-09-16 14:33:23 UTC
(In reply to Paolo Benvenuto from comment #8)
> Why WORKSFORME? the upgrade process does loose the selection, the bug is
> there!

So please try to update to LO7 and please desribe, what settings exactly get lost.
=> NEEDINFO
Comment 10 Paolo Benvenuto 2020-09-17 08:47:07 UTC
apparently upgrading from 6.4 to 7.0 doesn't loose any setting