Bug 136769 - when right-click creating a new writer file, default language is ignored
Summary: when right-click creating a new writer file, default language is ignored
Status: RESOLVED DUPLICATE of bug 133661
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 140867 (view as bug list)
Depends on:
Blocks: Options-Dialog-Language Languages
  Show dependency treegraph
 
Reported: 2020-09-15 12:49 UTC by warrior_hamster
Modified: 2021-06-12 10:40 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
win10 lang settings (390.47 KB, image/png)
2020-09-15 12:49 UTC, warrior_hamster
Details
libreoffice launcher language settings (41.24 KB, image/png)
2020-09-15 12:50 UTC, warrior_hamster
Details
right-click created file ignoring default UK language settings (4.14 KB, image/png)
2020-09-15 12:51 UTC, warrior_hamster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description warrior_hamster 2020-09-15 12:49:11 UTC
Description:
I believe I've done my due diligence (fingers crossed)
I'll add screenshots.
All my win10 language and keyboard options are default UK english.
All the default options in tools->languages in the libre launcher are default UK english.

As the summary states, when right-click creating a new writer file, default language is ignored and changes to US english.

If you create a new writer file through the libre launcher instead everything is fine and the default language is correct.

Steps to Reproduce:
1.Right click in a folder
2.click create new writer document
3.open new writer document
4.look at default language in the bottom bar of the document

Actual Results:
wrong text language/spellchecker is used

Expected Results:
same default language as if creating a new document from the launcher


Reproducible: Always


User Profile Reset: Yes



Additional Info:
N/A
Comment 1 warrior_hamster 2020-09-15 12:49:44 UTC
Created attachment 165522 [details]
win10 lang settings
Comment 2 warrior_hamster 2020-09-15 12:50:23 UTC
Created attachment 165523 [details]
libreoffice launcher language settings
Comment 3 warrior_hamster 2020-09-15 12:51:09 UTC
Created attachment 165524 [details]
right-click created file ignoring default UK language settings
Comment 4 warrior_hamster 2020-11-08 15:27:02 UTC
Can confirm, still occurs for me in 7.0.3
Comment 5 Martin Srdoš 2020-11-25 19:53:04 UTC
Hello Warior,

Thank you for reporting the bug. I can confirm that the bug is present in last release.

Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: cs-CZ (cs_CZ); UI: en-US
Calc: CL


No idea how to check it in master.
Comment 6 Dieter 2020-11-26 07:11:38 UTC
I confirm it with

Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

See Tools => Options => Language settings => Languages: Default language for documents changes from German (in my case) to English (USA). Thisonly happens if I create a new document from desktop or explorer.
Comment 7 Timur 2021-03-11 12:05:08 UTC
*** Bug 140790 has been marked as a duplicate of this bug. ***
Comment 8 Timur 2021-03-11 12:05:57 UTC
*** Bug 140867 has been marked as a duplicate of this bug. ***
Comment 9 Mike Kaganski 2021-06-12 10:40:37 UTC

*** This bug has been marked as a duplicate of bug 133661 ***