Download it now!
Bug 136782 - Frame/image duplication after cut & paste in DOCX
Summary: Frame/image duplication after cut & paste in DOCX
Status: RESOLVED DUPLICATE of bug 135893
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Frames
  Show dependency treegraph
 
Reported: 2020-09-15 16:15 UTC by Telesto
Modified: 2020-11-18 15:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (247.11 KB, application/vnd.oasis.opendocument.text)
2020-09-15 16:15 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-09-15 16:15:20 UTC
Description:
Frame/image duplication after cut & paste in DOCX

Steps to Reproduce:
1. Open the attached file
2. Save as DOCX
3. File reload
4. Cut the image frame with image
5. CTRL+V

Actual Results:
2 images

Expected Results:
1


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: abcc4eb907661e07ad850ccce7eb06f129da4286
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-09-15 16:15:36 UTC
Created attachment 165544 [details]
Example file
Comment 2 Telesto 2020-09-15 16:17:31 UTC
Also in
Version: 6.0.6.0.0+
Build ID: c30963b8b4bbbe42a24b97aafa161eff9d7ccdd4
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 3 Telesto 2020-09-15 16:18:00 UTC
And in
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 4 Telesto 2020-09-15 16:20:03 UTC
Not in
Versie: 4.1.0.4 
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28
Comment 5 BogdanB 2020-09-15 16:45:57 UTC
Confirmed with
Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 6 Xisco Faulí 2020-10-01 14:05:30 UTC
I'll bisect it but I fail to see why it's a high priority bug, in case a user hits this issue, they can always delete the second image
Comment 7 Attila Baraksó (NISZ) 2020-11-18 14:58:37 UTC
Fine in:

Version: 7.1.0.0.alpha1+
Build ID: 548d77d0c06f7088dd3eb408797aa1fc1d7eb277
CPU threads: 6; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: hu-HU (hu_HU.UTF-8); UI: en-US
Calc: threaded

and in:

Version: 7.1.0.0.alpha1+ (x64)
Build ID: 312a33b7636334f6ce3b6d1702bc5d3e45215601
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded
Comment 8 Attila Baraksó (NISZ) 2020-11-18 15:10:48 UTC
Reverse bibisected, this was the fix.

Bibisected using linux-64-7.1 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit?id=3ac675736066b47da7329269a01c1ef4a9cfe72a
author: Miklos Vajna <vmiklos@collabora.com>
committer: Miklos Vajna <vmiklos@collabora.com>
summary: tdf#135893 sw paste: fix copying fly frame in textbox twice
Comment 9 Attila Baraksó (NISZ) 2020-11-18 15:11:13 UTC

*** This bug has been marked as a duplicate of bug 135893 ***
Comment 10 Xisco Faulí 2020-11-18 15:16:43 UTC
(In reply to Attila Baraksó (NISZ) from comment #9)
> 
> *** This bug has been marked as a duplicate of bug 135893 ***

@Attila, thanks for the bisection.

@Telesto, this is another example of the same problem reported by you more than once. Please, recheck your own reports every now and then