Bug 136784 - FILEOPEN: PPTX: table in slide 2 is no longer displayed
Summary: FILEOPEN: PPTX: table in slide 2 is no longer displayed
Status: RESOLVED DUPLICATE of bug 118458
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: PPTX-Tables
  Show dependency treegraph
 
Reported: 2020-09-15 16:58 UTC by Xisco Faulí
Modified: 2021-06-09 12:31 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Comparison MSO 2010 and LibreOffice 7.1 master (54.74 KB, image/png)
2020-09-15 16:58 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-09-15 16:58:54 UTC
Created attachment 165546 [details]
Comparison MSO 2010 and LibreOffice 7.1 master

Steps to reproduce:
1. Open attachment 114222 [details] from bug 90140

-> The table in slide 2 is not visible. See comparison image

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 6f1e02c96b887750f974c187a82ecd6236e6a435
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2020-09-15 17:00:01 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c50ae6a282ed83762bf634fed5c91033eb305c88

author	Gülşah Köse <gulsah.kose@collabora.com>	2020-07-23 13:45:51 +0300
committer	Gülşah Köse <gulsah.kose@collabora.com>	2020-07-24 09:47:05 +0200
commit c50ae6a282ed83762bf634fed5c91033eb305c88 (patch)
tree 69901fbdb22ff1248673e73ceb6e4e31fe51d4ea
parent 785312dc11a78f72784c04a2e8e3183162a1e28b (diff)
tdf#133015 Fix duplicated row and column problem.

Bisected with: bibisect-linux64-7.1

Adding Cc: to Gülşah Köse
Comment 2 Timur 2020-11-10 10:52:54 UTC
Repro 7.1+.
Comment 3 Justin L 2021-01-16 16:57:41 UTC
Page 2's table is bhasSameSubTypeIndex, so it never fills the rTableGrid and thus is lost.

Regressions really need to be at least acknowledged, and preferably investigated soon after they are reported. I don't really understand the idea behind hasSameSubTypeIndex, but I suspect it needs major reworking.
Comment 4 NISZ LibreOffice Team 2021-06-09 12:31:01 UTC
As documented in https://bugs.documentfoundation.org/show_bug.cgi?id=120702#c4

attachment 172733 [details] shows the original file in todays nightly:

Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 31ed81ea71a20ec119805f66a42f99b3f80d2dc5
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: el-GR (hu_HU); UI: en-US
Calc: CL

Since multi columns text is no longer imported as table, this problem is just gone.

Is it possible though that it can appear with real tables? 

This is the only report referencing that commit hash, so marking as duplicate for now.

*** This bug has been marked as a duplicate of bug 118458 ***