Bug 136790 - presenter console: add option to show it in a seperate window (feature request, UI)
Summary: presenter console: add option to show it in a seperate window (feature reques...
Status: RESOLVED DUPLICATE of bug 33495
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-15 20:56 UTC by hardy
Modified: 2020-09-16 13:41 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hardy 2020-09-15 20:56:38 UTC
When showing a slide show with Impress, and using the "presenter console", then this presenter console is always shown in full screen mode.

This makes troubles to me in the following, currently very commmon usecase:

I want to show an Impress slide show in a video conference (i.e. hold an online lecture). I even have two monitors available for this. But currently I am unable to easily see the three things at once that I would like to see at once:
* the presentation itself (on one full screen, this screen is shared with the video conference tool)
* the slide notes, as shown on the presenter console
* the window of the video conferencing tool itself.

An (presumably not too difficult) improvement would be to

    give the user an option to show the presenter console content 
    not "full screen" but inside a normal "window". 

My monitor (and I assume this is not uncommon) would easily be big enough to show the windows with an Impress presenter console next to a second window with the video conferencing software. But since the presenter console can ONLY run full screen, this doesn't work yet.

This feature request is similar to bug 33495, but not identical, since I want to have the possibility to have free screen space next to the presenter console always (and not only once in a while, when minimizing the presenter console). But giving my suggested option to the user will then also fix bug 33495.

I am aways of the workaround, mentiond in bug 33495, to use Alt-Tab key to achieve a similar setup. But this workaround is sub-optimal. For example one can only use the video conferencing window then in a very elongated horizontal layout, because the presenter console puts the slide notes always in the top right corner of the full screen.

Please consider to improve LibreOffice to make it more "Corona useful", this would also be a very good feature that MS Office (to my knowledge) does not have yet.
Comment 1 Timur 2020-09-16 13:41:26 UTC
Other resize bugs were also duplicated to 33495.

*** This bug has been marked as a duplicate of bug 33495 ***