Download it now!
Bug 136793 - Size of sidebar cannot be reduced in Writer in Standard toolbar view
Summary: Size of sidebar cannot be reduced in Writer in Standard toolbar view
Status: RESOLVED DUPLICATE of bug 131947
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2020-09-16 05:52 UTC by andis.lazdins
Modified: 2020-10-01 10:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Enourmous sidebar size (123.15 KB, image/png)
2020-09-25 13:25 UTC, andis.lazdins
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andis.lazdins 2020-09-16 05:52:09 UTC
Description:
Size of sidebar cannot be reduced in Writer in Properties, Page, Navigator, Styles inspector, Manage changes and Themes tabs and takes up to 1/3 of screen.

Steps to Reproduce:
1.Open Writer document
2.In View menu activate Standard toolbar option
3.Activate sidebar if not active
4.Go to Properties or any other above mentioned tabs

Actual Results:
Sidebar expands to up to 1/3 of screen and it is not possible to reduce size. In contrast, in Styles tad it is possible to shrink size of sidebar manually.

Expected Results:
Sidebar can be resized and content of the sidebar rearranges according to it's size. Sidebar also should hold it's size during moving between tabs.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: lv-LV (en_US.UTF-8); UI: en-US
Calc: CL
Comment 1 Dieter 2020-09-19 16:02:05 UTC
Andis, do you think, we can treat this as a duplicate of bug 131947?
=> NEEDINFO
Comment 2 andis.lazdins 2020-09-19 17:19:29 UTC
(In reply to Dieter from comment #1)
> Andis, do you think, we can treat this as a duplicate of bug 131947?
> => NEEDINFO

It seems to be similar, however I don't have this issue with 6.4 as described in another report and on Windows 7 this issue is sligtly different, because it affects only Gallery tab. Other tabs in Windows can be reduced to reasonable size.
Comment 3 QA Administrators 2020-09-20 04:03:23 UTC Comment hidden (obsolete)
Comment 4 andis.lazdins 2020-09-25 13:24:39 UTC
This regression is just introduced in 6.4.7.1.
Only Styles tab can be reduced to reasonable size. Design tab is more than 1/3 of screen.
Somebody really have to take care for quality control of newly introduced Visual interface code.
I added screeshot to demonstrate the problem. Sidebar cannot be reduced.
Comment 5 andis.lazdins 2020-09-25 13:25:14 UTC
Created attachment 165847 [details]
Enourmous sidebar size
Comment 6 andis.lazdins 2020-09-25 13:27:05 UTC
(In reply to andis.lazdins from comment #4)
> This regression is just introduced in 6.4.7.1.
> Only Styles tab can be reduced to reasonable size. Design tab is more than
> 1/3 of screen.
> Somebody really have to take care for quality control of newly introduced
> Visual interface code.
> I added screenshot to demonstrate the problem. Sidebar cannot be reduced.

Correction - Gallery tab also can be reduced.
Comment 7 Heiko Tietze 2020-10-01 10:23:08 UTC
Likely a duplicate of bug 131947.

*** This bug has been marked as a duplicate of bug 131947 ***