Download it now!
Bug 136833 - Not able to delete a line with backspace with changes changes turned on
Summary: Not able to delete a line with backspace with changes changes turned on
Status: RESOLVED DUPLICATE of bug 135260
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: redlinehide-regressions
  Show dependency treegraph
 
Reported: 2020-09-17 06:45 UTC by Telesto
Modified: 2020-11-19 11:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (323.68 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-09-17 06:46 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-09-17 06:45:51 UTC
Description:
Not able to delete a line with backspace with changes changes turned on

Steps to Reproduce:
1. Open the attached file
2. Set the cursor at the end of the first line
3. Press backspace. Single letter removed

Actual Results:
Single letter removed

Expected Results:
Simply going on


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.2
Build ID: c01aa64b6c3d89ebe5fe69c28c7adb24eb85249c
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; VCL: osx
Locale: nl-NL (nl_NL.UTF-8); UI: en-US
Calc: threaded
Comment 1 Telesto 2020-09-17 06:46:13 UTC
Created attachment 165596 [details]
Example file
Comment 2 Telesto 2020-09-17 07:38:37 UTC
Also in
Version: 7.1.0.0.alpha0+ (x64)
Build ID: abcc4eb907661e07ad850ccce7eb06f129da4286
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

Still OK in
Version: 6.2.0.0.alpha0+
Build ID: 9d754a59154c40235c240bb0e7f47a2006fa85bd
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 3 Attila Baraksó (NISZ) 2020-09-17 10:26:15 UTC
Reproduced in:

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 8c18cd6823ddf4ef5ba67801a84cee26c9b5a9a6
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded
Comment 4 Attila Baraksó (NISZ) 2020-09-17 10:31:27 UTC
Bibisected using bibisect-win64-7.1 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=398ba26077f9029bdf6f7378bfc9ce8376b6f02d
author: Michael Stahl <Michael.Stahl@cib.de>
committer: Michael Stahl <Michael.Stahl@cib.de>
summary: tdf#127635 sw_redlinehide: put point at the end of deletion

Adding CC: Michael Stahl
Comment 5 Lars Jødal 2020-09-17 10:55:26 UTC
The original bug report ties it to a specific file. The problem is general.

Steps to reproduce:
1. Open a new Writer document and write something.
2. Turn on track-changes AND show track-changes.
3. Delete with backspace. Only a single letter is removed.

Actual results:
Cursor stays in its position, for which reason only a single letter is removed (put another way: deletion keeps to be of the same, already-deleted, letter)

Expected results:
Cursor should move with backspace deletion, allowing deletion of a string of letters by repeated backspace.

Reproducible: Always

User Profile Reset: No

Additional Info:

If track-changes are NOT shown, then deletion goes on as expected.

The bug appears to be a regression introduced by the fix to bug 127635.


Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU tråde: 4; Styresystem: Windows 10.0 Build 18362; Gengiver af brugergrænseflade: Skia/Raster; VCL: win
Locale: da-DK (da_DK); UI: da-DK
Calc: threaded

Also reproduced in:

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 4d33262b1b652b57f222c9f1cce7d976725399d4
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win
Locale: da-DK (da_DK); UI: da-DK
Calc: threaded
Comment 6 Telesto 2020-09-17 11:49:14 UTC
It simply bug 135260.. I'm re-doing my own report :-(

*** This bug has been marked as a duplicate of bug 135260 ***