Bug 136841 - Arrow image shows up black after docx export
Summary: Arrow image shows up black after docx export
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: SoftEdgeFallout
  Show dependency treegraph
 
Reported: 2020-09-17 10:33 UTC by Telesto
Modified: 2021-03-11 10:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-09-17 10:33:01 UTC
Description:
Arrow image shows up black after docx export

Steps to Reproduce:
1. open attachment 165568 [details]
2. Save as DOCX
3. File reload

Actual Results:
Image/shape page 2 black/gray

Expected Results:
Colored


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.1

not in
Version: 6.0.6.0.0+
Build ID: c30963b8b4bbbe42a24b97aafa161eff9d7ccdd4
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 raal 2020-09-18 08:57:02 UTC
Confirm with 7.1, bibisect later
Comment 2 NISZ LibreOffice Team 2020-09-18 12:10:40 UTC
Bibisected with win64-7.1 to:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=bf021c369f2306ee507da9bd3cc4cd10ac5d234c

author	Mike Kaganski <mike.kaganski@collabora.com>	2020-08-13 18:12:37 +0300
committer	Mike Kaganski <mike.kaganski@collabora.com>	2020-08-14 01:00:04 +0200

tdf#135500: always use transparent and clear content vdev in impBufferDevice
Comment 3 NISZ LibreOffice Team 2020-09-18 12:12:58 UTC
Adding CC to: Mike Kaganski

Also this is a display issue since the saved file appears with a red arrow in Word.
Comment 4 Xisco Faulí 2021-03-09 16:23:56 UTC
This issue is fixed by

author  Luboš Luňák <l.lunak@collabora.com>     2021-03-04 15:35:44 +0100
committer       Luboš Luňák <l.lunak@collabora.com>     2021-03-08 13:46:36
+0100
commit  6b8c157a0b4f37a09fdbf656919b2df06a3abc3e (patch)
tree    52451b3b5152511cb4fb68a2f09867bc9db85592
parent  db2e9619397f1e53232824a649b5ad0ba3dd368a (diff)
make RenderMaskPrimitive2DPixel() clip using clipping (tdf#140797)
Comment 5 Commit Notification 2021-03-11 10:52:42 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/076da4cd9d61adf15942a7bfc350bd0d268f64f1

tdf#136841: sw_ooxmlexport16: Add unittest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.