Bug 136872 - Inconsistent comment deletion behavior (and not matching anchors)
Summary: Inconsistent comment deletion behavior (and not matching anchors)
Status: RESOLVED DUPLICATE of bug 120290
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Comments
  Show dependency treegraph
 
Reported: 2020-09-18 08:38 UTC by Telesto
Modified: 2020-12-16 06:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (9.97 KB, application/vnd.oasis.opendocument.text)
2020-09-18 08:39 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-09-18 08:38:51 UTC
Description:
Inconsistent comment deletion behavior (and not matching anchors)

Steps to Reproduce:
1. open the attached file
2. Place cursor at the end of the first line (behind cd)
3. Press backspace until v -> Comment gone
4. Go to the fourth line.. and press backspace (comment anchor moves)

Actual Results:
Anchor is deleted instead of moving

Expected Results:
Moving comment anchor


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: abcc4eb907661e07ad850ccce7eb06f129da4286
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-09-18 08:39:02 UTC
Created attachment 165650 [details]
Example file
Comment 2 Telesto 2020-09-18 08:40:47 UTC
@Michael
Should the comment anchoring be comparable with the image anchor behavior?
Comment 3 Michael Stahl (allotropia) 2020-09-18 08:43:52 UTC
comments should behave like as-character flys, with the character at the start of the comment anchor.
Comment 4 Mike Kaganski 2020-09-18 09:10:54 UTC
This is the distinction *where* (relative to the anchor) the cursor is put. On the fourth line, when you *click* there, the cursor is put after all the text, *but before the anchor*. If you press right arrow then, the cursor will go after the anchor (note how the line from anchor to the comment changes its appearance from solid to dashed line). Also the cursor is *after* the anchor if the step 4 (loosely expressed as "Go to the fourth line") is performed using Ctrl+End.

So the behaviour of anchor movement here is perfectly consistent. What is questionable is placement of cursor after the left mouse click.
Comment 5 Telesto 2020-09-18 11:50:42 UTC
(In reply to Mike Kaganski from comment #4)
> This is the distinction *where* (relative to the anchor) the cursor is put.
> On the fourth line, when you *click* there, the cursor is put after all the
> text, *but before the anchor*. If you press right arrow then, the cursor
> will go after the anchor (note how the line from anchor to the comment
> changes its appearance from solid to dashed line). Also the cursor is
> *after* the anchor if the step 4 (loosely expressed as "Go to the fourth
> line") is performed using Ctrl+End.

These observations are correct. FWIW: those differences are bit to subtle for me. For me a cursor is a cursor. If I'm it around with mouse (click) or keyboard. So I don't even comes to mind looking at those aspects 

For the record Click at the first line after the 'v' and the 'comment' anchor as such will be selected (which is also pretty nasty, if you ask me)


Another 'annoyance' (bit out of scope here).
Type AAA + Insert comment (type something in it) back to main doc, Press arrow left & start typing.. The comment anchor while be in the middle. And no clue how to solve that. Except reinserting comment box (or if possible undo & restart).

The selection issue with the mouse is also obvious in bug 136879 (more or less causing the undo problem; or making the issue more prominent)
Comment 6 Telesto 2020-09-18 12:04:27 UTC
(In reply to Telesto from comment #5)
> For the record Click at the first line after the 'v' and the 'comment'
> anchor as such will be selected (which is also pretty nasty, if you ask me)

-> Appears to be a regression; created a new bug 136880
Comment 7 Justin L 2020-12-16 06:16:03 UTC
Step 4 - the part about the cursor being placed BEFORE the comment instead of AFTER the comment was fixed in 7.2.

*** This bug has been marked as a duplicate of bug 120290 ***