Bug 136879 - The marked comment area is gone after undo cut/paste operation
Summary: The marked comment area is gone after undo cut/paste operation
Status: RESOLVED DUPLICATE of bug 120290
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Undo-Redo Writer-Comments
  Show dependency treegraph
 
Reported: 2020-09-18 11:47 UTC by Telesto
Modified: 2022-03-05 16:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (9.71 KB, application/vnd.oasis.opendocument.text)
2020-09-18 11:47 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-09-18 11:47:07 UTC
Description:
The marked comment area is gone after undo cut/paste operation

Steps to Reproduce:
1. Open the attached file
2. Select the full first line with the mouse
3. CTRL+X and undo (or drag and drop it below --- and undo)

Actual Results:
Marking gone (or more precise limited to small area)

Expected Results:
Not so


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: abcc4eb907661e07ad850ccce7eb06f129da4286
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-09-18 11:47:20 UTC
Created attachment 165659 [details]
Example file
Comment 2 Telesto 2020-09-18 11:48:44 UTC
It's also hard to include the comment within the selection (with the mouse)
Comment 3 Telesto 2020-09-18 11:54:31 UTC
Also in 4.4.7.2

not in
Versie: 4.2.0.4 
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Comment 4 BogdanB 2020-09-18 17:13:36 UTC
Confirm in
Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 5 Attila Baraksó (NISZ) 2020-09-24 14:28:46 UTC
Reproduced in:

Version: 7.1.0.0.alpha0+
Build ID: 121771e37f7e2de41cd5643475861062bf25627b
CPU threads: 6; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-GB (hu_HU.UTF-8); UI: en-US
Calc: threaded
Comment 6 Attila Baraksó (NISZ) 2020-09-24 14:30:26 UTC
Bibisected using linux bibisect-43max to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=0761f81643a6890457e9ef7d913ab5c88c2593a4
author: Oliver-Rainer Wittmann <orw@apache.org>
committer: Miklos Vajna <vmiklos@collabora.co.uk>
summary: 123792: complete annotations on text ranges feature
Comment 7 BogdanB 2021-07-27 05:22:11 UTC
Seems ok in Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 612d5b1a04fe022a34018d901bb9b052791d54e5
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

Telesto could you retest this bug?
Comment 8 Justin L 2022-03-05 15:08:12 UTC
Note that if you select two lines it worked.  So it was a selection issue.
Fixed in LO 7.1.

*** This bug has been marked as a duplicate of bug 120290 ***
Comment 9 Timur 2022-03-05 16:15:26 UTC
(In reply to BogdanB from comment #7)
> Seems ok in Version: 7.3.0.0.alpha0+ / LibreOffice Community
> Telesto could you retest this bug?

If you confirm (again) with 7.0 and don't repro with master, just close as WFM.