Download it now!
Bug 136885 - find-replace - when cursor is in comment box, focus and cursor returns to page in document with comment, after clicking in document
Summary: find-replace - when cursor is in comment box, focus and cursor returns to pag...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Search Writer-View-Jumps
  Show dependency treegraph
 
Reported: 2020-09-18 23:00 UTC by sdc.blanco
Modified: 2020-09-29 11:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test document with steps to reproduce bug included in comment box (10.11 KB, application/vnd.oasis.opendocument.text)
2020-09-18 23:00 UTC, sdc.blanco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2020-09-18 23:00:27 UTC
Created attachment 165675 [details]
Test document with steps to reproduce bug included in comment box

Test document attached - or use a multi-page document with at least one comment.

1.  Place cursor in comment box.
2.  Find-and-replace (Ctrl-H)
3.  Search for anything that is on another page.
4.  Click cursor in the found page (e.g., on the found word, or elsewhere in that page).

Actual behavior:  Cursor is returned to the page where the comment box appears.

Expected behavior:  Cursor remains where clicked.

Additional information.

1.  The cursor returns on a line a few lines from the top of the comment box and seems take the same horizontal position in the canvas where clicked.

2. Related to bug 121478, but not exactly the same behavior. In that case, ESC, out of the Find-Replace dialog returns the cursor to the comment box. In this case, the cursor returns to the document page with the comment.

Produced with 6.3.6.2 and 7.0.0.0.beta2
Comment 1 Thomas Lendo 2020-09-27 15:22:23 UTC
Dear bug opener, please retest this issue with the newest daily build of LibreOffice:

https://dev-builds.libreoffice.org/daily/master/

(These builds are installable in parallel to a "production release" of LibreOffice.)


I can reproduce this issue with

Version: 6.0.7.3
Build-ID: 1:6.0.7-0ubuntu0.18.04.10
CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

but NOT with

Version: 7.1.0.0.alpha0+
Build ID: a8c218a52a639b0e7f689dea878a0421702628e0
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-09-25_22:25:07
Calc: threaded
Comment 2 sdc.blanco 2020-09-29 11:54:14 UTC
I agree that something has changed from 7.0.0.0.beta2 and 7.1.0.0.alpha0+ 
Cannot reproduce, so I will close as WFM.

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 3c6177be2705303044e3de262689d593f3d0f282
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: da-DK (en_DK); UI: en-US
Calc: threaded