Bug 136916 - Underline menu lines not visible in dark mode
Summary: Underline menu lines not visible in dark mode
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.4.0 target:7.3.5
Keywords:
Depends on:
Blocks: UI-Theming Icon-Themes Icon-Theme-Breeze Icon-Theme-Sifr
  Show dependency treegraph
 
Reported: 2020-09-21 10:16 UTC by medmedin2014
Modified: 2022-05-26 11:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Underline lines not visible (91.59 KB, image/png)
2020-09-21 10:16 UTC, medmedin2014
Details

Note You need to log in before you can comment on or make changes to this bug.
Description medmedin2014 2020-09-21 10:16:11 UTC
Created attachment 165715 [details]
Underline lines not visible

The lines in underline menu are not visible. See attached image for more info.

Version: 7.0.1.2
Build ID: 00(Build:2)
CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: en-US (en_US.UTF-8); UI: en-US
=7.0.1-1
Calc: threaded

Operating System: Manjaro Linux
KDE Plasma Version: 5.19.5
KDE Frameworks Version: 5.73.0
Qt Version: 5.15.0
Kernel Version: 5.4.64-1-MANJARO
OS Type: 64-bit
Comment 1 Александра Пилипон 2021-07-22 07:06:13 UTC
don't repro in 

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: c5ca46e75e28ba4245d8544ca53c71fea87d1bbd
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-US (ru_UA); UI: en-GB
Calc: threaded
Comment 2 medmedin2014 2021-07-22 08:05:55 UTC
This problem is specific to Linux, you should install Manjaro KDE or Kubuntu or any Linux distro with KDE desktop manager and set OS theme to dark to test it.
Comment 3 medmedin2014 2021-09-29 14:18:03 UTC
It's still repro on KDE with VCL: fk5

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: b60b6bfaafa1315e07108dba50f016975b619c59
CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-09-28_03:43:58
Calc: threaded

Operating System: Manjaro Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.4.144-1-MANJARO (64-bit)
Graphics Platform: X11
Comment 4 Michael Weghorn 2022-01-04 11:22:03 UTC
I can reproduce bad contrast for this case when using the Plasma Breeze Dark theme with

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 7a4250b74b53c8f5d650319dfe0509ce9dd80900
CPU threads: 12; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded
Comment 5 Jan-Marek Glogowski 2022-05-25 13:12:15 UTC
So I just checked svx/uiconfig/ui/textunderlinecontrol.ui / svx/source/sidebar/text/TextUnderlineControl.cxx and unfortunately (because I can't fix it easily) found, that these lines aren't painted by LO, but are actually icons (icon-themes/*/svx/res/symphony/line*).

So this needs new icons for the dark icon sets. Nothing VCL or even plugin specific.

I would prefer an non-icon implementation, so the popup would select the correct line color and "just" paint the lines, like LO does for underlining the text, but that is much more work.
Comment 6 Jan-Marek Glogowski 2022-05-25 13:17:45 UTC
Ohh - icon-themes/colibre_dark*/svx/res/symphony/line* exists, so probably just copy that into other dark icon sets? Or some proper fallback for dark icon themes, so we just need these line icons once?
Comment 7 Commit Notification 2022-05-26 05:27:52 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/84706376e333ca5cf9ccb9a2c08daef93fa3b16d

Breeze & Sifr tdf#136916 add dark underlines variant icons

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2022-05-26 06:40:31 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/f56cbeccb35c569d6ca1c6ecffed160379845957

Breeze & Sifr tdf#136916 add dark underlines variant icons

It will be available in 7.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.