Bug 136969 - Table Borders Needs Something Similar to Word
Summary: Table Borders Needs Something Similar to Word
Status: RESOLVED DUPLICATE of bug 96576
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-23 08:34 UTC by EasyGoingPat
Modified: 2021-02-10 08:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Recording of Microsoft Word drawing a simple table (2.10 MB, video/mp4)
2020-11-14 09:22 UTC, EasyGoingPat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description EasyGoingPat 2020-09-23 08:34:28 UTC
Description:
I have just about weaned myself off Word and onto Libre Writer. The one thing I can't get round is how hard it is to put custom borders around cells.

A common scenario for me is to use two thicknesses of border. I will use the thickest to go round the whole table and to separate the top-row and left-column 'titles' from the 'values' area of the table. In Word, I simply select the whole table and apply the thinner border to every cell and then I use the Draw Table tool to apply the thicker borders by clicking individual lines I want to go thicker. Try as I might, I can't figure out how to do this in Writer.

The problem I am having is that, when I go to apply the thicker borders, it 'wipes out' any thinner borders I have already applied to a cell.

One easy way to do it might be to have an option where every subsequent border applied to a cell is applied either as an addition or a subtraction from what is there - a bit like masks in programs like GIMP. Though I don't think even this would be anywhere near as easy to use as the Word way of doing things.



Steps to Reproduce:
Please see description above.

Actual Results:
Unable to achieve custom patterns of borders in table cells.

Expected Results:
Though I hate to say it, it is hard to see how you could beat the MS Word way of doing this.


Reproducible: Always


User Profile Reset: No



Additional Info:
Maybe it would need a video to fully describe what I mean.
Comment 1 Timur 2020-09-23 09:42:32 UTC
Please search existing bugs to see if already reported. 
And if not, attach some screenshot with the explanation.
Comment 2 EasyGoingPat 2020-11-14 09:22:52 UTC
Created attachment 167298 [details]
Recording of Microsoft Word drawing a simple table

I have attached a recording of the way Word draws a simple table. Unfortunately, the drop-down menus don't show up in the recording. I use drop-downs twice:

(1) The first time is just a gimmick for setting the initial number of rows and columns and is not much easier than the Libre Writer method of entering the number of rows and columns.

(2) The second time, I am choosing a line thickness for drawing.

Notice also that the table-drawing sub-menu also includes an erase button, which allows whole lines in the table or just individual borders of single boxes to be erased. This makes it very easy to create completely non-standard table layouts (e.g. you could fairly easily use the tool to draw a representation of a Tetris game).

Hope this helps.

- Patrick
Comment 3 QA Administrators 2020-11-15 03:44:38 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2021-02-10 06:11:37 UTC
Looking at the video, it seems your request matches bug 96576. Is this correct?
Comment 5 EasyGoingPat 2021-02-10 07:58:19 UTC
Yes, it appears so.

I have added a comment to that bug, to support the suggestion.

- Patrick
Comment 6 Buovjaga 2021-02-10 08:02:23 UTC
Great, let's close this one

*** This bug has been marked as a duplicate of bug 96576 ***