Download it now!
Bug 136999 - FILEOPEN XLSX Textbox vertical left alignment disappears
Summary: FILEOPEN XLSX Textbox vertical left alignment disappears
Status: VERIFIED DUPLICATE of bug 137023
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx, regression
Depends on:
Blocks: XLSX-Shapes
  Show dependency treegraph
 
Reported: 2020-09-24 12:12 UTC by NISZ LibreOffice Team
Modified: 2020-11-09 13:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the original document side by side in Excel and Calc (176.20 KB, image/png)
2020-09-24 12:13 UTC, NISZ LibreOffice Team
Details
Example file from Excel (9.65 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-09-24 12:13 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-09-24 12:12:32 UTC
Description:
Textbox in an Excel spreadsheet loses its “Vertical alignment: Center” property after saved as .xlsx and opened in Calc.

Steps to Reproduce:
    1. Create a textbox in an Excel spreadsheet
    2. Type some text
    3. Click left on the textbox border and choose “Size and properties”
    4. In the toolbar on the right, open “Textbox”
    5. Set the vertical alignment to Center. Attachment contains examples for all options available in this field, the other five works fine.
    6. Save the document in XLSX format
    7. Open the file in Calc

Actual Results:
The vertical alignment changed to Center Center.

Expected Results:
The vertical alignment should have stayed Center.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 52a49f9e480ca03e231cfda82640a928393131c9
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded

Not happening yet in:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: bcf1917a0934417226d2357b514df398129a7fab
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL
(latest verstion from bibisect-win64-7.1 repo, 13 days ago)

Maybe it’s connected with https://bugs.documentfoundation.org/show_bug.cgi?id=129685.
Comment 1 NISZ LibreOffice Team 2020-09-24 12:12:43 UTC
Adding CC to Miklos Vajna
Comment 2 NISZ LibreOffice Team 2020-09-24 12:13:38 UTC
Created attachment 165813 [details]
Screenshot of the original document side by side in Excel and Calc
Comment 3 NISZ LibreOffice Team 2020-09-24 12:13:55 UTC
Created attachment 165814 [details]
Example file from Excel
Comment 4 Xisco Faulí 2020-09-29 08:16:54 UTC
I believe we can close this as a dupe of bug 137023
Both pptx and xlsx used the same oox code

*** This bug has been marked as a duplicate of bug 137023 ***
Comment 5 NISZ LibreOffice Team 2020-11-09 13:08:36 UTC
Verified in:

Version: 7.1.0.0.alpha1+ (x64)
Build ID: d3cee4f3839e22754e167e89d25acd6ccacf0b6e
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded