Bug 137064 - Writer treats rotated images like they have not been rotated when moving the image
Summary: Writer treats rotated images like they have not been rotated when moving the ...
Status: RESOLVED DUPLICATE of bug 115934
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-27 02:58 UTC by BDF
Modified: 2020-09-27 06:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
odt test file (98.49 KB, application/vnd.oasis.opendocument.text)
2020-09-27 03:00 UTC, BDF
Details
all black arrow as SVG (2.38 KB, image/svg+xml)
2020-09-27 03:00 UTC, BDF
Details
RED tipped arrow (2.42 KB, image/svg+xml)
2020-09-27 03:01 UTC, BDF
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BDF 2020-09-27 02:58:52 UTC
Description:
When you import a non-square image and rotate it by 90° Writer treats the image's bounding box like it has never been rotated.
When you want to move the image to the page's edge, Writer keeps a distance as if the image has not been rotated.

Steps to Reproduce:
1. Import a non-square image
2. rotate it by 90°
3. try to move it to the edge of the page where the image has been larger before

Actual Results:
Image can not be placed on the edge of the page

Expected Results:
The image can be placed on the edge of the page like you can do it when you import the image already rotated.


Reproducible: Always


User Profile Reset: No



Additional Info:
Document info:
In the odt file there are two files in use: The all black arrow is pointing up as is. The arrow with the RED TIP is pointing to the right by default.

In the .odt file the arrow with the red tip has been rotated 90° to the left so that it matches the arrow that is all black.

The image size is set to: 5cm on the short side, to not interact with text, anchored on the page (this does not seem to matter at all, it's just for better visibility)

The image with the RED TIPPED arrow can _not_ be moved to the far right (or left) even it should fit by the displayed bounding box. It can be moved over the top of the page though even it moves the image out of the visible area.

I have tested this with SVG, PNG and JPG files both as linked and inluded files.
The interesting thing I noticed: When you rotate the all black arrow, everything works fine. So the rotated all black arrow can be moved all the way to the top. When the all black rotated arrow is moved to the very bottom of a page, it will have the same bug.

----------------------------------------------------------------------

Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win
Locale: de-AT (de_AT); UI: de-DE
Calc: threaded
Comment 1 BDF 2020-09-27 03:00:13 UTC
Created attachment 165878 [details]
odt test file
Comment 2 BDF 2020-09-27 03:00:48 UTC
Created attachment 165879 [details]
all black arrow as SVG
Comment 3 BDF 2020-09-27 03:01:19 UTC
Created attachment 165880 [details]
RED tipped arrow
Comment 4 Dieter 2020-09-27 06:05:01 UTC
Sounds to me like a duplicate of bug117855, that has been marked as a duplicate of bug 115934.

=> RESOLVED DUPLICATE

Please feel free to change it back to UNCONFIRMED with a short reasoning, if you disagree.

*** This bug has been marked as a duplicate of bug 115934 ***