Bug 137129 - FILEOPEN DOCX: Frame (with position right relative to margin) appearing on wrong side (left)
Summary: FILEOPEN DOCX: Frame (with position right relative to margin) appearing on wr...
Status: RESOLVED DUPLICATE of bug 124481
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Frames
  Show dependency treegraph
 
Reported: 2020-09-29 15:38 UTC by Rhys Young
Modified: 2021-04-30 11:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The test file (22.02 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-09-29 15:40 UTC, Rhys Young
Details
Minimized example file with a manually added frame (23.40 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-12-07 13:16 UTC, NISZ LibreOffice Team
Details
The simplified example file in Word 2013 and Writer 7.2master (110.36 KB, image/png)
2020-12-07 13:17 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rhys Young 2020-09-29 15:38:06 UTC
Description:
When opening the attached file in LO the page number appears on the left side instead of the right.

Steps to Reproduce:
1. Open attached file in word see that the page number is on the right side.
2. Open attached file in latest LO see that the page number is on the left side.


Actual Results:
Page number is on left side

Expected Results:
Page number should be on right side


Reproducible: Always


User Profile Reset: No



Additional Info:
N/a
Comment 1 Rhys Young 2020-09-29 15:40:17 UTC
Created attachment 165949 [details]
The test file
Comment 2 Timur 2020-10-02 09:04:22 UTC
Repro OO 3.3 to LO 7.1+.
It's not page number but frame (regardless that page number is in it), with position right relative to margin, also to page or column.
Could be a duplicate, I couldn't find.
Comment 3 NISZ LibreOffice Team 2020-12-07 13:16:30 UTC
Created attachment 167900 [details]
Minimized example file with a manually added frame

I tried to remove as much formatting from the original frame as possible and make it look like a newly inserted frame, but no luck:
- without having it in the header, without containing page number, without separatet character and paragraph styles, with fixed size and added border, it is converted in Writer to a simple paragraph.
- Just added a new frame in Word in the same file and that is imported as a frame.

I have no idea what's missing. This used to work in 3.5 and 3.6.0 but started to be broken in 4.0 - that's not really bibisectable :(.
Comment 4 NISZ LibreOffice Team 2020-12-07 13:17:25 UTC
Created attachment 167901 [details]
The simplified example file in Word 2013 and Writer 7.2master

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 561e5559bb68242c7f785f0ca3bee3eb12b58963
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL
Comment 5 NISZ LibreOffice Team 2020-12-07 13:30:43 UTC
Opening up the file shows that this frame is inside an sdt content control, with this "template":

<w:docPartGallery w:val="Page Numbers (Top of Page)"/>
Comment 6 Timur 2021-04-30 11:41:12 UTC
Looks duplicate.

*** This bug has been marked as a duplicate of bug 124481 ***