Bug 137232 - Some print ranges are lost when saving
Summary: Some print ranges are lost when saving
Status: RESOLVED DUPLICATE of bug 51022
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print-Range
  Show dependency treegraph
 
Reported: 2020-10-03 20:00 UTC by Charles Vollum
Modified: 2021-07-28 05:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charles Vollum 2020-10-03 20:00:17 UTC
Description:
In spreadsheets that are linked to other files, the last page returns to a status of -none- even when Format/Print Ranges/Edit is set to -entire sheet- and the spreadsheet is saved. The setting is retained until the file is closed (with saving) and then reopened. I have not seen this on sheets other than the last one, and I have not seen this on spreadsheets that are self-contained (do not reference other files).

Steps to Reproduce:
1. open .ods file linked to another spreadsheet
2. select last sheet
3. Format/Print Ranges/Edit now shows -none-
4. from Format/Print Ranges/Edit select -entire sheet-
5. Click OK
6. Close file, Save Changes
7. Reopen file
8. Format/Print Ranges/Edit now shows -none-

Actual Results:
Every time I want to print pages including the last one, I need to reset the Print Range to -entire sheet- for the last page. It's print range keeps reverting to -none- every time the document is reopened.

Expected Results:
After saving the document with Print Range set to -entire sheet- it should always be -entire sheet- until I change it.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Flatpak
Calc: threaded
Comment 1 m.a.riosv 2020-10-06 18:06:10 UTC
Can you attach a sample file with the issue?
Comment 2 NISZ LibreOffice Team 2021-01-28 08:05:44 UTC
The description sounds like bug #51022

Could you test with a fresh nightly build if this problem still persists:

https://dev-builds.libreoffice.org/daily/master/current.html

If yes, please upload am example file.
Comment 3 QA Administrators 2021-07-28 04:06:04 UTC Comment hidden (obsolete)
Comment 4 BogdanB 2021-07-28 05:16:55 UTC
Indeed, seems very similar to 51022

*** This bug has been marked as a duplicate of bug 51022 ***