Bug 137243 - FILESAVE DOCX: "Header" for "endnote" page not saved !
Summary: FILESAVE DOCX: "Header" for "endnote" page not saved !
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Header-Footer DOCX-Footnote-Endnote
  Show dependency treegraph
 
Reported: 2020-10-04 15:06 UTC by yousifjkadom
Modified: 2020-12-30 05:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test (5.21 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-10-05 12:03 UTC, yousifjkadom
Details
screenshot (62.70 KB, image/png)
2020-10-05 12:04 UTC, yousifjkadom
Details
test-1 (10.04 KB, application/vnd.oasis.opendocument.text)
2020-10-05 16:34 UTC, yousifjkadom
Details
test-2 (10.25 KB, application/vnd.oasis.opendocument.text)
2020-10-05 16:35 UTC, yousifjkadom
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yousifjkadom 2020-10-04 15:06:48 UTC
Description:
As the title saying. 
When I tried to add "Header" for the "endnote" page, the changed not saved & header disappeared after colsing then re-opened the document !

Actual Results:
Should be saved.

Expected Results:
Not saved, & disappear after closing then re-open the document.


Reproducible: Always


User Profile Reset: No



Additional Info:
I'm using flatpak from FlatHub on my Fedora 32 X64 bit Cinnamon edition.
Comment 1 Dieter 2020-10-05 06:48:09 UTC
I've tried the following steps

1. Open new document
2. change page style to "Endnote"
3. Enable header and write some text
4. Save, close and reopen

Couldn't reproduce the bug.

Is your bug about page style "Endnote" or about a document with andnotes (and perhaps a different page style. If this is the please describe the steps to reproduce or add a sample document.

=> NEEDINFO
Comment 2 yousifjkadom 2020-10-05 11:56:29 UTC
It is a document (theses) that I used add endnotes to it's paragraphs, so I have at end of a document a page with "endnote style" generated by program. The issue is related to this last page of document which composed totally from 16 pages. At this last page (for references) I tried to add a header "References", but it can not saved !

I can not attached document because the theses still not published in a scientific journal .... I will try to create new document to attached it here.
Comment 3 yousifjkadom 2020-10-05 12:02:39 UTC
I created new document "test" & tried it & issue reproduced. I added to 2nd page a header "References" (see attached screenshot) & saved it, then closed document. After that I re-opened it but header disappeared !
Comment 4 yousifjkadom 2020-10-05 12:03:06 UTC
Created attachment 166086 [details]
test
Comment 5 yousifjkadom 2020-10-05 12:04:38 UTC
Created attachment 166087 [details]
screenshot
Comment 6 Dieter 2020-10-05 12:16:43 UTC
(In reply to yousifjkadom from comment #4)
> Created attachment 166086 [details]
> test

Thank for test document. It's important to know, that you've saved it as docx-file. Could you please attach the original odt-file? Thanks.
Comment 7 yousifjkadom 2020-10-05 14:30:44 UTC
There is no original .odt file because I'm in a country where no one use it ! For that I'm enforced to use .docx format though it is closed source. I'm already set my LO to save document by default as a docx. & pptx.

Best.
Comment 8 Dieter 2020-10-05 14:54:54 UTC
(In reply to yousifjkadom from comment #7)
> There is no original .odt file because I'm in a country where no one use it
> ! For that I'm enforced to use .docx format though it is closed source. I'm
> already set my LO to save document by default as a docx. & pptx.

But since you've created the file with LO, you're able to save it as odt. Please do so and attach this file.
Comment 9 yousifjkadom 2020-10-05 16:34:00 UTC
Hi. I attached 2 .odt files:

test-1.odt which is a copy from .docx before adding & saving header. This to be fresh copy.

test-2.odt which is a copy from .docx after adding & saving header WHILE it is still opened not closed. 

As you see, header is kept saved correctly in test-2.odt though it is lost from original .docx after close it & re-opened it again.
Comment 10 yousifjkadom 2020-10-05 16:34:29 UTC
Created attachment 166096 [details]
test-1
Comment 11 yousifjkadom 2020-10-05 16:35:06 UTC
Created attachment 166097 [details]
test-2
Comment 12 Dieter 2020-10-05 17:10:27 UTC
I confirm it with

Version: 7.0.2.2 (x64)
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: he-IL (de_DE); UI: en-GB
Calc: threaded

Steps to reproduce

1. Open attachment 166097 [details] (see header with text on page 2)
2. Save as docx, close and reopen

No header on page 2 (same result when docment is opened in MS Word 2016)


Additional information:
I think, you want to add a heading to the endnote page. That is actually not possible but requested in bug 89736.
Comment 13 Justin L 2020-12-30 05:40:44 UTC
DOCX format does not know about page styles.

Plus, the endnote page styles is not a real page break/section anyway. It is just some automatic thing that happens.

In other words, this is all just complete emulation between two different ways of handling endnotes. There is no one-to-one correspondence between what LibreOffice can do and what DOCX can do. The header/footer is something that DOCX doesn't have, so it will just be "lost".

WONTFIX.