Bug 137259 - Misleading Help descriptions for the BETAINV and BETA.INV functions of Calc
Summary: Misleading Help descriptions for the BETAINV and BETA.INV functions of Calc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2020-10-05 08:40 UTC by Steve Fanning
Modified: 2022-03-09 17:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Fanning 2020-10-05 08:40:40 UTC
Description:
The description of the first argument to these functions reads "Number is the value between Start and End at which to evaluate the function". This appears to be incorrect - the Start and End values are intended to constrain the results of the functions, not the input probability.

Suggest clarify that Number is the probability associated with the BETA
distribution for other given arguments (Alpha and Beta). Also suggest updating the descriptions of the Start and End arguments to reflect that they define a range for the output of the function.

Finally it may be worth adding a comment about the defaults applied when Start and End are not specified.

Steps to Reproduce:
1. View relevant Help page
2.
3.

Actual Results:
N/A

Expected Results:
N/A


Reproducible: Always


User Profile Reset: No



Additional Info:
N/A
Comment 1 Rafael Lima 2022-01-10 19:49:46 UTC
Indeed, the Number parameter is actually the cumulative probability for which the X value is to be found.

If Start and End are note defined, then default values are 0 and 1, respectively (see [1]).

[1] https://opengrok.libreoffice.org/xref/core/sc/source/core/tool/interpr3.cxx?r=37429f26#2213
Comment 2 Commit Notification 2022-02-12 20:02:07 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/b3a3a1b9968d7735d4fe3c201b52c9a4942f1e09

tdf#137259 Update BETAINV and BETA.INV description