Bug 137325 - "Keep with next paragraph" not applied after deleting a paragraph
Summary: "Keep with next paragraph" not applied after deleting a paragraph
Status: RESOLVED DUPLICATE of bug 139656
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Styles-Paragraph
  Show dependency treegraph
 
Reported: 2020-10-08 09:20 UTC by Telesto
Modified: 2021-07-23 17:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (11.92 KB, application/vnd.oasis.opendocument.text)
2020-10-08 09:20 UTC, Telesto
Details
Bibisect log (2.89 KB, text/plain)
2020-10-08 16:04 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-10-08 09:20:22 UTC
Description:
"Keep with next paragraph" not applied at undo (based on bug 137319)

Steps to Reproduce:
1. Open the attached file
2. Press Enter on page 2 after the yellow marking. Text moves up
3. CTRL+Z
4. CTRL+Z

Actual Results:
Paragraph still on first page

Expected Results:
Back to original state


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.2
Build ID: c01aa64b6c3d89ebe5fe69c28c7adb24eb85249c
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; VCL: osx
Locale: nl-NL (nl_NL.UTF-8); UI: en-US
Calc: threaded
Comment 1 Telesto 2020-10-08 09:20:40 UTC
Created attachment 166178 [details]
Example file
Comment 2 Telesto 2020-10-08 16:04:52 UTC
Created attachment 166200 [details]
Bibisect log

Bisected to:
author	Nickson Thanda <nicksonthanda10@msn.com>	2018-06-22 04:59:16 +0100
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2018-07-02 09:32:29 +0200
commit 391134e4cc0cf444ac50c6df02073de57ad9c466 (patch)
tree 4a4c32f9054606ff96789e278bdc6bdd79711832
parent f54143088a867c59be144f1d4d7cd6d9fe1c18f5 (diff)
tdf#51223 can now undo auto-capitalise with enter

https://cgit.freedesktop.org/libreoffice/core/commit/?id=391134e4cc0cf444ac50c6df02073de57ad9c466
Comment 3 Dieter 2020-10-20 16:18:40 UTC
I confirm it with

Version: 7.0.2.2 (x64)
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: he-IL (de_DE); UI: en-GB
Calc: threaded

You get the same wrong result, if you delete the new paragraph.
=> I've changed bug summary

cc: Nickson Thanda
Comment 4 Timur 2021-03-09 11:08:34 UTC
*** Bug 139656 has been marked as a duplicate of this bug. ***
Comment 5 Justin L 2021-03-26 14:52:12 UTC
This example and bibisect are completely bogus. Pressing Enter automatically capitalized the first letter, so just change it to a capital X right away, save the document, and test without that complicating factor. Then you see the same problem happening, and no amount of undoing triggers a reformat.

Testing this way shows it doesn't work at least since 3.5, probably inherited from OOo.

So I am just going to mark this as INVALID, and make the duplicate the real bug report since it isn't as misleading.
Comment 6 BogdanB 2021-07-22 21:43:24 UTC
*** Bug 139656 has been marked as a duplicate of this bug. ***
Comment 7 Telesto 2021-07-23 17:40:23 UTC

*** This bug has been marked as a duplicate of bug 139656 ***