Bug 137329 - White borders in Slide Show mode (F5) in Impress with SKIA
Summary: White borders in Slide Show mode (F5) in Impress with SKIA
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:7.0.4
Keywords:
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2020-10-08 10:21 UTC by JonIrenicus
Modified: 2020-11-23 20:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
White borders in Slide show mode of Impress (18.09 KB, image/png)
2020-10-08 10:24 UTC, JonIrenicus
Details
No repro Win with Lo 7.0 or 7.1+ (175.68 KB, image/png)
2020-10-09 06:45 UTC, Timur
Details
Example file (9.77 KB, application/vnd.oasis.opendocument.presentation)
2020-10-21 15:15 UTC, Telesto
Details
Screenshot (15.33 KB, image/jpeg)
2020-10-21 15:15 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JonIrenicus 2020-10-08 10:21:50 UTC
Description:
When open a slide in full screen mode with F5-key (Slide Show -> Start from First Slide), there are white (light gray) lines on black background at borders (left and top sides). 
See screenshot attached.

Steps to Reproduce:
1. Open Impress
2. Create NEW Presentation
3. Select any Template
4. Start slideshow (press F5)


Actual Results:
There are white (light gray) lines are visible now at left and top side of the border

Expected Results:
There are no borders in full screen (slide show) at all!


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Windows 10.0 Build 17763; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded
Comment 1 JonIrenicus 2020-10-08 10:24:16 UTC
Created attachment 166182 [details]
White borders in Slide show mode of Impress
Comment 2 Timur 2020-10-08 16:21:56 UTC Comment hidden (obsolete)
Comment 3 JonIrenicus 2020-10-08 17:50:52 UTC
(In reply to Timur from comment #2)
> This is probably for specific presentation that you need to attach.

No, its for the all presentations, including default (created from the template.
Comment 4 Telesto 2020-10-09 06:23:13 UTC
Somewhat similar to bug 136940
Comment 5 Timur 2020-10-09 06:44:42 UTC
Until proven otherwise, let's mark duplicate. 
I guess this is "Blue Curve". I do not repro, meaning that this may be due to video card or monitor resolution, or hardware acceleration setting in Tools-Options-View. 
Please try all and write here, and in bug 136940 where discussion continues. 


Note: you may use link  attachment 166182 [details].

*** This bug has been marked as a duplicate of bug 136940 ***
Comment 6 Timur 2020-10-09 06:45:12 UTC
Created attachment 166222 [details]
No repro Win with Lo 7.0 or 7.1+
Comment 7 JonIrenicus 2020-10-09 08:09:13 UTC
(In reply to Timur from comment #6)
> Created attachment 166222 [details]
> No repro Win with Lo 7.0 or 7.1+

Yes, I don't have lines in 1920x1080, but when I switch to 1920x1200 - there are white lines.
Comment 8 JonIrenicus 2020-10-09 10:21:06 UTC
The problem was in Skia (Software rendering).
I turned off the option:
Options -> LibreOffice -> View -> Use Skia for all rendering
Comment 9 Timur 2020-10-09 10:57:38 UTC
Please do not close, it's not fixed, you just have a workaround.
Comment 10 Telesto 2020-10-21 15:15:10 UTC
Created attachment 166593 [details]
Example file
Comment 11 Telesto 2020-10-21 15:15:51 UTC
Created attachment 166594 [details]
Screenshot
Comment 12 Commit Notification 2020-11-19 20:45:43 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5b292e878703ebc32e875406f4116cba145a9042

avoid Skia floating point position fixups for rectangles (tdf#137329)

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-11-23 20:40:29 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/4de9f35aef7a96a3c034e8a7ed5006ab36e5984a

avoid Skia floating point position fixups for rectangles (tdf#137329)

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.