Bug 137347 - Selecting text with CTRL+SHIFT arrow up /down not working in Impress Text frames
Summary: Selecting text with CTRL+SHIFT arrow up /down not working in Impress Text frames
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: sdc.blanco
URL:
Whiteboard: target:7.2.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2020-10-08 20:25 UTC by Telesto
Modified: 2020-12-30 03:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (11.84 KB, application/vnd.oasis.opendocument.presentation)
2020-10-08 20:25 UTC, Telesto
Details
Bibisect log (2.91 KB, text/plain)
2020-10-08 21:16 UTC, Telesto
Details
screenshot for updated help page (23.84 KB, image/png)
2020-12-29 13:57 UTC, sdc.blanco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-10-08 20:25:07 UTC
Description:
Selecting text with CTRL+SHIFT arrow up /down not working in Impress Text frames

Steps to Reproduce:
1. Open the attached file
2. Enter the textbox
3. Press CTRL+SHIFT arrow down (nothing

Actual Results:
Not working

Expected Results:
Should work IMHO


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.1

and in
Version: 7.0.0.0.beta1+ (x64)
Build ID: 2891e91a513520d68ea2b8c59c14335861a15253
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-10-08 20:25:29 UTC
Created attachment 166205 [details]
Example file
Comment 2 Telesto 2020-10-08 21:16:56 UTC
Created attachment 166209 [details]
Bibisect log

Bibisected to:
author	Philippe Jung <phil.jung@free.fr>	2015-11-19 00:51:13 +0100
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2015-11-19 11:55:25 +0000
commit	8f07a723f932ac83b48afe55518b0a1e81e36f20 (patch)
tree	8e0736fa06504ca2dc09147fe84d18d0f310eaa8
parent	c94cf0cf5f10edb45a74a58c95c306b0d271645b (diff)
tdf#91909 Add shortcuts for MovePage actions
Ctrl+Shift+Home: Move page first
Ctrl+Shift+Up: Move page up
Ctrl+Shift+Down: move page down
Ctrl+Shift+End: mov page last

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8f07a723f932ac83b48afe55518b0a1e81e36f20
Comment 3 Telesto 2020-10-08 21:21:58 UTC
@Samuel 
Adding you as opportunistically, being the one committing the patch. Don't think the author will fix this (Philippe Jung)
Comment 4 sdc.blanco 2020-12-29 13:03:14 UTC
This is a documentation bug.

Look in Tools > Customize > Keyboard  under Ctrl+Shift+{Arrow Up,Arrow Down}
where you will see that these keys correspond to move Page (Slide) up (or down).

If you add a few empty slides to your test file, then you can use these commands to move the first slide up and down.   (i.e., nothing is broken)

Your bibisect simply found the intended change in 5.1

Changed is needed here in documentation:

https://help.libreoffice.org/7.2/en-US/text/simpress/04/01020000.html
Comment 5 sdc.blanco 2020-12-29 13:57:03 UTC
Created attachment 168556 [details]
screenshot for updated help page

The attached screenshot is the proposal for the patched help page 
( https://gerrit.libreoffice.org/c/help/+/108341/ )

The Ctrl+Shift+Arrow keys work in the Slide Sorter and Slide Pane.
Comment 6 Commit Notification 2020-12-29 14:39:22 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/e5aeb1d6368a566f2c10920af77ede9042ac3e8a

tdf#139286 and tdf#137347 update slide sorting shortcut keys in Impress