Bug 137353 - Remote Files SSH doesn't connect at all
Summary: Remote Files SSH doesn't connect at all
Status: RESOLVED DUPLICATE of bug 98723
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.6.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-08 21:37 UTC by Sean M. Pappalardo
Modified: 2020-10-09 18:49 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sean M. Pappalardo 2020-10-08 21:37:52 UTC
Description:
When trying to use Remote Files to connect to a Windows server running OpenSSH, LibO appears not to connect at all according to the server log.

Steps to Reproduce:
1. Install OpenSSH Server component on a Windows server on a custom port.
2. Test from a command line SSH client on the LibO machine to ensure it works.
3. Start LibO, go to Remote Files.
4. Add service, choose SSH. Enter server name, port, credentials. Save.
5. Click on the service name.

Actual Results:
Nothing happens in LibO and the server logs no authentication attempts.

Expected Results:
LibO should try to connect to the SSH server!


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.4.6.2 (x64)
Build ID: 0ce51a4fd21bff07a5c061082cc82c5ed232f115
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

Note that SSHing to a Windows server requires using DOS commands instead of Linux/UNIX ones. (E.g. "dir" instead of "ls")

Is LibO using the SFTP variant of SSH? If so, the service name should say that instead of "SSH."
Comment 1 Julien Nabet 2020-10-09 18:49:34 UTC

*** This bug has been marked as a duplicate of bug 98723 ***