Bug 137354 - LibreOffice logo distorted on About Page
Summary: LibreOffice logo distorted on About Page
Status: RESOLVED DUPLICATE of bug 137311
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: About-Dialog
  Show dependency treegraph
 
Reported: 2020-10-08 22:07 UTC by mwtjunkmail
Modified: 2020-12-21 14:42 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
distorted logo (10.05 KB, image/png)
2020-10-08 22:09 UTC, mwtjunkmail
Details
Distorted logo with AA (6.81 KB, image/png)
2020-10-09 02:50 UTC, mwtjunkmail
Details
Not distorted logo for Linux Version: 7.1.0.0.alpha0+ Build ID: 7aaa9ef2e5edaf468f116449776433e98fb1a2f3 (204.30 KB, image/png)
2020-10-11 15:38 UTC, Joao Farias
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mwtjunkmail 2020-10-08 22:07:31 UTC
Description:
The LO logo in the upper right corner of the about page is distorted/faint.

Steps to Reproduce:
1. Launch LO
2. Go to about page

Actual Results:
Logo should not look like attachment

Expected Results:
Should not be distorted.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.2.2 (x64)
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 8; OS: Windows 10.0 Build 20226; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 1 mwtjunkmail 2020-10-08 22:09:09 UTC
Created attachment 166210 [details]
distorted logo
Comment 2 mwtjunkmail 2020-10-08 22:09:56 UTC
Also happening in

Version: 7.1.0.0.alpha0+ (x64)
Build ID: f90500754fac014638214b5e061832b2c518aab6
CPU threads: 8; OS: Windows 10.0 Build 20226; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 3 Ming Hua 2020-10-08 22:59:07 UTC
If you have anti-aliasing disabled (Tools > Options > LibreOffice > View > Use anti-aliasing), then this is a duplicate of bug 136633.
Comment 4 mwtjunkmail 2020-10-09 02:47:43 UTC
(In reply to Ming Hua from comment #3)
> If you have anti-aliasing disabled (Tools > Options > LibreOffice > View >
> Use anti-aliasing), then this is a duplicate of bug 136633.

It's the same with or without AA.
Comment 5 mwtjunkmail 2020-10-09 02:50:16 UTC
Created attachment 166213 [details]
Distorted logo with AA

Version: 7.0.2.2 (x64)
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 8; OS: Windows 10.0 Build 20231; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 6 mwtjunkmail 2020-10-09 02:52:24 UTC
I also thought it might be because in Windows 10, I had text size globally set to 110% percent, but reverting text size to 100% did not change the outcome.
Comment 7 Ming Hua 2020-10-10 01:36:47 UTC
(In reply to mwtjunkmail from comment #4)
> It's the same with or without AA.
I see.

There is also bug 137311, although it's specific to Linux and GTK3.
Comment 8 Joao Farias 2020-10-11 15:38:32 UTC
Created attachment 166272 [details]
Not distorted logo for Linux Version: 7.1.0.0.alpha0+ Build ID: 7aaa9ef2e5edaf468f116449776433e98fb1a2f3
Comment 9 Joao Farias 2020-10-11 15:41:34 UTC
On the current daily build for Linux, I don't see such a distorted logo as in the attachements (1) and (2)

1 - http://bugs.documentfoundation.org/attachment.cgi?id=166210 
2 - https://bug-attachments.documentfoundation.org/attachment.cgi?id=166153

Version: 7.1.0.0.alpha0+
Build ID: 7aaa9ef2e5edaf468f116449776433e98fb1a2f3
CPU threads: 8; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-10-09_22:58:32
Calc: threaded
Comment 10 Xisco Faulí 2020-10-12 15:47:39 UTC
bug 137311 was fixed today.
Could you please try again with a daily build containing the fix for bug 137311? likely it will be available tomorrow or the day after
Comment 11 mwtjunkmail 2020-10-13 03:45:13 UTC
Hi. I do not use LibreOffice in an Linux environment. 
Why do people insist on testing in Linus when I post problems in Windows?

Rare is it than anyone testing in Linux ever finds the same bugs that I do in Windows. Linux < > Windows.

I have this windows build:

Version: 7.1.0.0.alpha0+ (x64)
Build ID: fca525d570f4fada3db1a9bbee2e88a5a02839d9
CPU threads: 8; OS: Windows 10.0 Build 20231; UI render: default; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

I will wait for the next daily build and re-test, as requested.

But PLEASE:

Test. Using. A Windows. Build.
Comment 12 QA Administrators 2020-10-13 04:48:35 UTC Comment hidden (obsolete)
Comment 13 mwtjunkmail 2020-10-14 00:35:33 UTC
Waiting on a new cut of Win-x86_64@tb77-TDF and then I'll be able to test.
Comment 14 Telesto 2020-10-14 07:01:51 UTC
I'm not seeing this in 
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 7f16cabf00daa30e9284d2fb2494bd341352c25e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

However this build 12 days old
Comment 15 mwtjunkmail 2020-10-14 09:58:36 UTC
Works for me under

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 94e6e140491de31c0788c91af855a75a3bb12709
CPU threads: 8; OS: Windows 10.0 Build 20231; UI render: default; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 16 Xisco Faulí 2020-10-14 10:02:19 UTC
(In reply to mwtjunkmail from comment #15)
> Works for me under
> 
> Version: 7.1.0.0.alpha0+ (x64)
> Build ID: 94e6e140491de31c0788c91af855a75a3bb12709
> CPU threads: 8; OS: Windows 10.0 Build 20231; UI render: default; VCL: win
> Locale: en-US (en_US); UI: en-US
> Calc: threaded

In the original report you were using skia, now you are not using it
Comment 17 mwtjunkmail 2020-10-14 19:00:56 UTC
(In reply to Xisco Faulí from comment #16)
> (In reply to mwtjunkmail from comment #15)
> > Works for me under
> > 
> > Version: 7.1.0.0.alpha0+ (x64)
> > Build ID: 94e6e140491de31c0788c91af855a75a3bb12709
> > CPU threads: 8; OS: Windows 10.0 Build 20231; UI render: default; VCL: win
> > Locale: en-US (en_US); UI: en-US
> > Calc: threaded
> 
> In the original report you were using skia, now you are not using it

Skia / no Skia, AA / No AA, didn't matter. Logo was screwed it up every way I looked at it.

I posted the last config that I used when I updated the bug. I tested against all configs.

In my production work, I must avoid using Skia (and often AA) because using Skia with AA when exporting to PNG still anti-aliases objects on a draw slide to white even with a transparent background. Half of what I do has transparent backgrounds. Result, artifacts on the output everywhere. Hardware with no AA in these most recent versions of the daily build doesn't have that problem.

Just to confirm for this bug report, the following works for the logo:

AA w/ Skia
AA w/ Hardware acceleration


GOOD NEWS (if off-topic), I *REALLY* like the blurred drop shadow functionality. Very professional, and rivals other programs. Very nice, and as long as I'm using a non-transparent background, which encompasses the other half of what I do, the PNG output is great.

I've gotten to the point when I want to use the PNG output to wrap around 3D objects, when the object demands transparency anywhere, I use hardware / no AA, and if a solid background, I can switch to Skia with AA.

And what's nice, I don't have to switch back to Skia at all most of the time, because hardware with no AA still produces a great PNG output with blurred shadows as long as the background isn't transparent.

Very much liking that feature.
Comment 18 mwtjunkmail 2020-10-31 15:51:21 UTC
Logo is indistinct just as before in 

Version: 7.1.0.0.alpha1 (x64)
Build ID: 987671387712c4f9061d6216ff2f001a7bb9e57b
CPU threads: 8; OS: Windows 10.0 Build 20246; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 19 mwtjunkmail 2020-11-01 19:37:31 UTC
And someone must have noticed.

Works now with

Version: 7.1.0.0.alpha1+ (x64)
Build ID: a689cf1672e89cb78fbcfa14c505850927e71f58
CPU threads: 8; OS: Windows 10.0 Build 20246; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

and I see that the little tag line underneath the logo has been removed, which is probably a good thing, considering how small the text was.
Comment 20 Xisco Faulí 2020-11-02 10:08:27 UTC
Most likely a dupe of bug 137311

*** This bug has been marked as a duplicate of bug 137311 ***