Bug 137406 - Crash when clicking "Apply to Master" in Slide Master mode on Bullets and Numbering dialog
Summary: Crash when clicking "Apply to Master" in Slide Master mode on Bullets and Num...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Gökçe Kuler
URL:
Whiteboard: target:7.2.0 target:7.1.1 target:7.0.5
Keywords: bibisected, bisected, haveBacktrace
Depends on:
Blocks:
 
Reported: 2020-10-12 03:34 UTC by Kevin Suo
Modified: 2021-02-17 08:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
gdbtrace.log (19.07 KB, text/x-log)
2020-10-12 03:34 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2020-10-12 03:34:09 UTC
Created attachment 166285 [details]
gdbtrace.log

Steps to Reproduce:
1. New Impress, click Cancel when you are asked to select a template.
2. Change to Master Slide mode by clicking "View > Master Slide".
3. Click the first outline text (i.e., "Click to edit the outline text format"), then right-click -> Bullets and Numbering.
4. Click "Apply to Master", then click OK.

-> Crash.

Terminal Outout:
warn:legacy.tools:538325:538325:svx/source/svdraw/svdpage.cxx:1558: TRG_GetMasterPage(): No MasterPage available. Use TRG_HasMasterPage() before access (!)

gdbtrace attached.
Comment 1 Kevin Suo 2020-10-12 03:35:21 UTC
Can reproduce in both
Version: 6.4.6.2
Build ID: 0ce51a4fd21bff07a5c061082cc82c5ed232f115
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3; 
Locale: zh-CN (zh_CN.UTF-8); UI-Language: en-US
Calc: threaded

and master as of today.
Comment 2 Xisco Faulí 2020-10-12 11:59:29 UTC
The dialog was added in

author	Gülşah Köse <gulsah.kose@collabora.com>	2019-04-17 20:00:18 +0300
committer	Miklos Vajna <vmiklos@collabora.com>	2019-05-23 10:16:30 +0200
commit	e3015d7021e689c71c2ed8e5dd01a74d832c84f0 (patch)
tree	5fe68d52d35d9f2df506f1cf61e2bcc020469766
parent	237a656db82951e06f8a34e6ca2c1e50f24eb508 (diff)
Add new customize and position merged dialog

Since then, it crashes

Adding Cc: to Gülşah Köse
Comment 3 Commit Notification 2021-02-13 16:50:22 UTC
Gokce Kuler committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9887674044e17c4925caa07f197d74233be810d2

tdf#137406 removed Apply to Master button in Slide Master mode

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2021-02-15 16:11:54 UTC
Gokce Kuler committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/18d22eaf191b854508f4f34b57e931c26d2f34db

tdf#137406 removed Apply to Master button in Slide Master mode

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2021-02-16 12:21:33 UTC
Gokce Kuler committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/ed6033cb0b5fef681015fe574761ebe3fd60be5b

tdf#137406 removed Apply to Master button in Slide Master mode

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2021-02-17 08:07:11 UTC
Gokce Kuler committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-1":

https://git.libreoffice.org/core/commit/ff4a65a15080b63ee13aa2818fb9700858e58eba

tdf#137406 removed Apply to Master button in Slide Master mode

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.