Bug 137413 - FILEOPEN: EMF image is no longer transparent
Summary: FILEOPEN: EMF image is no longer transparent
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.1.0 target:7.2.0 target:7.1....
Keywords: bibisected, bisected, regression
: 136978 136979 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-10-12 09:13 UTC by Xisco Faulí
Modified: 2021-02-25 12:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (556.48 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-10-12 09:13 UTC, Xisco Faulí
Details
Comparison MSO 2010 and LibreOffice 7.1 master (25.52 KB, image/png)
2020-10-12 09:14 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-10-12 09:13:00 UTC
Created attachment 166290 [details]
sample file

Steps to reproduce:
1. Open attached document

-> The image is not transparent. See comparison image

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: a9976a958b2857e308c6598532151878615bfd9f
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2020-10-12 09:14:05 UTC
Created attachment 166291 [details]
Comparison MSO 2010 and LibreOffice 7.1 master
Comment 2 Xisco Faulí 2020-10-12 09:15:10 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d75c5b38911557173c54a78f42ff220ab3918573

author	Miklos Vajna <vmiklos@collabora.com>	2020-09-17 13:21:52 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2020-09-17 17:21:44 +0200
commit	d75c5b38911557173c54a78f42ff220ab3918573 (patch)
tree	ee1d3b2a7c9a280f71a5a6bb65f4ea088555a467
parent	007e6063931bd87d6ce15deb65b9adc823f74ce0 (diff)
tdf#136836 emfio: speed up import of EMF import when the orig PDF is available

Bisected with: bibisect-linux64-7.1

Adding Cc: to Miklos Vajna
Comment 3 Timur 2020-10-12 10:54:12 UTC
Looks the same as in bug 136979.
Comment 4 Commit Notification 2020-10-27 10:22:09 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4a35c118a3a6b954827953674cc9bad435c394ee

tdf#137413 EMF import: fix transparency in the PDF fallback case

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Timur 2020-10-28 07:22:13 UTC
Looks good, I set Verified. 
Although bibisected commit is different from the same bug 136836, attachment 165754 [details] from bug 136979 is also good. 
Also seems fixed is attachment 165752 [details] (from the same bug) that I reported as bug 136978, thinking it was different issue.

Xisco, when making comparison "MSO and LibreOffice" (I'd expect MSO is first from the left) you don't really follow the order, so not clear what's what. Please leave some UI or write what's what or at least follow left-to-right order.
Comment 6 Timur 2020-10-28 07:22:51 UTC
*** Bug 136978 has been marked as a duplicate of this bug. ***
Comment 7 Timur 2020-10-28 07:23:21 UTC
*** Bug 136979 has been marked as a duplicate of this bug. ***
Comment 8 Miklos Vajna 2020-10-28 07:58:38 UTC
(In reply to Timur from comment #5)
> Xisco, when making comparison "MSO and LibreOffice" (I'd expect MSO is first
> from the left) you don't really follow the order, so not clear what's what.

Yes, that confused me in the past as well. :-)

> Please leave some UI or write what's what or at least follow left-to-right
> order.

Or just change the wording to say "LibreOffice and MSO" (for future reports), so when one carefully reads the description and looks at the picture, the order matches. I imagine that's much easier to do.
Comment 9 Xisco Faulí 2020-10-28 11:58:27 UTC
ouch, sorry for that, I'll try to be more careful about that in the future
Comment 10 Commit Notification 2021-02-12 10:02:12 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f52c5bea7775ac07cfacc232f0979a03bbdf9aa7

fix test for tdf#137413

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2021-02-15 09:18:29 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/ed6d37c3a24dd238cbf7fef47068318599fcfcb3

fix test for tdf#137413

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-02-25 12:18:59 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-1":

https://git.libreoffice.org/core/commit/9b8500bbbe9a738fed6ba4b54e11cfecd0c34977

fix test for tdf#137413

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.