Bug 137426 - Native file chooser no longer used on macOS
Summary: Native file chooser no longer used on macOS
Status: RESOLVED DUPLICATE of bug 137573
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-12 13:57 UTC by Thorsten Wagner
Modified: 2020-10-18 08:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (120.58 KB, image/png)
2020-10-12 13:57 UTC, Thorsten Wagner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Wagner 2020-10-12 13:57:15 UTC
Description:
When opening new files, the native file chooser according to the OS should be used. This is no longer the case and the stock file chooser is used instead (see screenshot attached).

Steps to Reproduce:
1. Open LibreOffice Startcenter
2. Open new file by choosing Open File menu item on Startcenter sidebar

Actual Results:
Stock file chooser is displayed

Expected Results:
macOS native file chooser is displayed


Reproducible: Always


User Profile Reset: No



Additional Info:
Issue exists on current revision of master.
Comment 1 Thorsten Wagner 2020-10-12 13:57:41 UTC
Created attachment 166306 [details]
Screenshot
Comment 2 Telesto 2020-10-12 20:08:47 UTC
Repro
Comment 3 Telesto 2020-10-18 08:56:58 UTC

*** This bug has been marked as a duplicate of bug 137573 ***