Bug 137458 - SVG image appears blurry with 200% scaling
Summary: SVG image appears blurry with 200% scaling
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
7.0.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.2 target:7.0.6
Keywords: regression
Depends on:
Blocks: HiDPI GTK3
  Show dependency treegraph
 
Reported: 2020-10-13 15:35 UTC by Frederic Parrenin
Modified: 2021-05-02 08:22 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
.svg image to reproduce the problem (37.43 KB, image/svg+xml)
2020-10-13 15:35 UTC, Frederic Parrenin
Details
.png screenshot of writer with the .svg file inserted (419.37 KB, image/png)
2020-10-13 19:18 UTC, Frederic Parrenin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2020-10-13 15:35:07 UTC
Created attachment 166351 [details]
.svg image to reproduce the problem

Steps to reproduce:
- open a new document in writer
- insert the attached .svg image
=> the image appears blurry.
It appears correctly in LO 6.4.6, so this is a regression in 7.0
Comment 1 Xisco Faulí 2020-10-13 19:06:31 UTC
I can't reproduce it in

Version: 7.1.0.0.alpha0+
Build ID: 0b3ff97d7d5a1e8471e494f4141165364203c192
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Could you please attach a screenshot a paste the information from Help - About LibreOffice ?
Comment 2 Frederic Parrenin 2020-10-13 19:18:00 UTC
Created attachment 166354 [details]
.png screenshot of writer with the .svg file inserted

My version of LO is:

Version: 7.0.2.2
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 8; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); UI: en-US
Calc: threaded

I use debian 11 with wayland, and I have a 4k screen (with 200% scaling), so maybe this is related.
Comment 3 Frederic Parrenin 2020-10-13 19:25:56 UTC
I have tested that the file does not appear blurry when using a scaling of 100%.
So it seems something has changed in 7.0 with respect to the scaling of 4k screens.
Comment 4 QA Administrators 2020-10-14 04:31:48 UTC Comment hidden (obsolete)
Comment 5 Timur 2020-10-14 14:12:54 UTC
See bug 130678 and bug 133066 if this is a duplicate.
Comment 6 Frederic Parrenin 2020-10-14 14:47:24 UTC
@Timur: no, I don't think it is a dup of bug 130678 or bug 133066.
These former bugs happened already with 6.4 and concern the icons.
This new bug is 7.0-only and happens with in-document svg images.
Comment 7 Frederic Parrenin 2020-10-14 14:51:00 UTC
BTW, I checked that the problem also happens on X11, on writer, impress and calc.
Comment 8 Frederic Parrenin 2020-11-26 16:58:48 UTC
I just checked that this problem still show up in LO 7.0.3 and 7.1.0-beta1.
For me this problem is a bit unfortunate, since I work on 4k screens and I have to stay on the 6.4 version for this reason.
Comment 9 frontrunner_medicophysical 2020-11-29 11:55:07 UTC
(In reply to Frederic Parrenin from comment #8)
> I just checked that this problem still show up in LO 7.0.3 and 7.1.0-beta1.
> For me this problem is a bit unfortunate, since I work on 4k screens and I
> have to stay on the 6.4 version for this reason.

Does this appimage work for you: https://libreoffice.soluzioniopen.com/stable/basic/LibreOffice-6.4.7-x86_64.AppImage

For me, even in 6.4.7 the svgs are blurry, although in different ways. In 6.4.7 circles looks like octagons, while in 7.0 they are anti-aliased.

Svg icons are also blurry, in the anti-aliased way.
Comment 10 Frederic Parrenin 2020-11-29 20:04:54 UTC
@frontrunner_medicophysical@aleeas.com, yes, the appimage you mentioned work for me. But this is 6.4, and my problem is with 7.0 and 7.1.
Comment 11 Telesto 2020-12-04 07:21:13 UTC
No issue on macOS
Version: 7.1.0.0.alpha1+
Build ID: c784b3da15102caf1022e83371863a86766e69cd
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; VCL: osx
Locale: nl-NL (nl_NL.UTF-8); UI: en-US
Calc: threaded
Comment 12 Telesto 2020-12-04 07:23:00 UTC
(In reply to Frederic Parrenin from comment #10)
> @frontrunner_medicophysical@aleeas.com, yes, the appimage you mentioned work
> for me. But this is 6.4, and my problem is with 7.0 and 7.1.

https://libreoffice.soluzioniopen.com/pre/7.1/LibreOffice-7.1.0.0.beta1-x86_64.AppImage
Comment 13 Frederic Parrenin 2020-12-04 14:45:54 UTC
Same problem for me with your appimage version of 7.1: svg images still appear blurry.
Comment 14 Frederic Parrenin 2021-02-03 15:00:25 UTC
I checked that this problem is still present in 7.1.0.
It is present with or without hardware acceleration and with or without smoothing.
However, the bug does not show up in slideshow.
Comment 15 Frederic Parrenin 2021-02-03 16:55:41 UTC
I checked that the bug is not present on Windows.
Comment 16 Roman Kuznetsov 2021-03-12 20:10:07 UTC
Frederic can you test it in LibreOffice with vcl:kde5 backend? Do you have a virtual machine with KDE?
Comment 17 Frederic Parrenin 2021-03-13 09:27:59 UTC
@Roman: I am not sure how I can install the vcl:kde5 backend on my debian 11 box. I installed both kde and the libreoffice-kde5 package, but what I get is the vcl:kf5 backend when I launch libreoffice.

With the vcl:kf5 backend, there is not problem with the svg images even with a 200% scaling. It seems also that the icons in the toolbars are not blurry.
Comment 18 Roman Kuznetsov 2021-03-13 12:21:50 UTC
Seems like GTK3 problem
Comment 19 Aron Budea 2021-05-02 02:23:47 UTC
Fortunately this is fixed now, by the following commit, reverse-bibisected using repo bibisect-linux-64-7.2.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=6b8c157a0b4f37a09fdbf656919b2df06a3abc3e
author		Luboš Luňák <l.lunak@collabora.com>	2021-03-04 15:35:44 +0100
committer	Luboš Luňák <l.lunak@collabora.com>	2021-03-08 13:46:36 +0100

"make RenderMaskPrimitive2DPixel() clip using clipping (tdf#140797)"

There's a line in the commit message referring to this aspect:
"As a side-effect this also seems to fix tdf#115843 again."
Comment 20 Frederic Parrenin 2021-05-02 08:22:51 UTC
Thank you for the information @Aron.
I tested 7.1.2 and indeed, this issue seems to be fixed.
This is a great news!

However, there are other issues which are still present with 4k displays, like the blurry toolbars with svg icons (#128998), or the blurry slide sorter in Impress (#122535).
I hope these other issues will also be fixed.