Download it now!
Bug 137615 - Crash when opening the effect sidebar panel
Summary: Crash when opening the effect sidebar panel
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords:
: 137696 (view as bug list)
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2020-10-20 09:20 UTC by Heiko Tietze
Modified: 2020-10-24 09:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2020-10-20 09:20:42 UTC
The newly introduced Effect panel, see https://gerrit.libreoffice.org/c/core/+/103835, crashes the application when expanding the panel. Happens in PanelLayout::GetOptimalSize() where m_xContainer is nil.
Comment 1 andreas_k 2020-10-23 06:51:29 UTC
*** Bug 137696 has been marked as a duplicate of this bug. ***
Comment 2 Commit Notification 2020-10-23 15:07:41 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ec9b799b48b7e93809d4ccbb6b8b3ea1642f7a13

Resolves: tdf#137615 fix EffectPropertyPanel

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.