Bug 137646 - CPU usage & lag doing basic typing
Summary: CPU usage & lag doing basic typing
Status: RESOLVED DUPLICATE of bug 113104
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-21 09:16 UTC by info
Modified: 2020-11-10 09:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example document with graphics and lag (88.79 KB, application/vnd.oasis.opendocument.text)
2020-10-21 09:17 UTC, info
Details

Note You need to log in before you can comment on or make changes to this bug.
Description info 2020-10-21 09:16:43 UTC
Description:
Typing or scrolling is extremely laggy on a 6 core 2018 Macbook Pro using internal graphics adapter (e.g. no external monitor)
Using an external monitor mitigates the problem somewhat by thowing a full dedicated GPU at it, but that is an overkill in order to get a word processor to function acceptably.

CPU usage is 50% whilst typing in the document... this is due to the inserted graphics object - improved slightly if anchor type is changed to "as character" from "to character"- but still only marginally acceptable on a modern computer.

It makes LO usage almost impossible for serious work. 

This has been a problem since LO6 and the graphics back-end change in LO7 has unfortunately not improved this at all. 

I have tried all the reset profiles, OpenGL options, turn off spell check etc throughout the years, but this makes no difference.

Steps to Reproduce:
1. Open document
2. Type
3. Wait

Actual Results:
Typing on a moderm computer should be instant + low CPU usage (5%?)

Expected Results:
Lag, high CPU


Reproducible: Always


User Profile Reset: Yes



Additional Info:

Version: 7.0.2.2
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 12; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: nb-NO (en_NO.UTF-8); UI: en-US
Calc: threaded
Comment 1 info 2020-10-21 09:17:34 UTC
Created attachment 166571 [details]
Example document with graphics and lag
Comment 2 Telesto 2020-10-21 15:06:41 UTC
Retina screen I assume
Comment 3 Xisco Faulí 2020-11-10 09:35:33 UTC
it looks like a duplicate of bug 113104

*** This bug has been marked as a duplicate of bug 113104 ***