Bug 137661 - default print range lines appear in spreadsheet without user interaction
Summary: default print range lines appear in spreadsheet without user interaction
Status: RESOLVED DUPLICATE of bug 124983
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print-Range
  Show dependency treegraph
 
Reported: 2020-10-21 15:32 UTC by Dean3430
Modified: 2021-07-30 08:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
before resizing a column (99.55 KB, image/png)
2020-10-21 19:23 UTC, Dean3430
Details
after resizing a column (102.13 KB, image/png)
2020-10-21 19:24 UTC, Dean3430
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dean3430 2020-10-21 15:32:47 UTC
Description:
Every time I resize a column or row, the lines of the default print range appear in the spreadsheet. The only way to make them disappear is to exit and reload the document, but then they reappear as soon as I resize a column or a row.

Steps to Reproduce:
1. create a spreadsheet
2. exit the document
3. reload the document
4. resize a column or a row

Actual Results:
The lines of the print range appear

Expected Results:
The lines of the print range does not appear (by default)


Reproducible: Always


User Profile Reset: Yes



Additional Info:
It can be disabled at Menu/Tools/Options/LibreOffice calc/View - Visual Aids - Page breaks, but that disables also the manual print ranges which I don't want.
I think there should be a way to prevent this.

I tested on Linux 6.4.6.2, Linux 7.0.2.2 and Windows 10 6.4.6.2
Comment 1 m.a.riosv 2020-10-21 17:57:01 UTC
I cant' repro.
Version: 7.1.0.0.alpha0+ (x64)
Build ID: df74aef7159d7155addf78cfc4d139485945d794
CPU threads: 4; OS: Windows 10.0 Build 20180; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); UI: en-US
Calc: CL
Comment 2 Dean3430 2020-10-21 19:23:34 UTC
Created attachment 166601 [details]
before resizing a column
Comment 3 Dean3430 2020-10-21 19:24:11 UTC
Created attachment 166602 [details]
after resizing a column
Comment 4 Dean3430 2020-10-21 19:33:12 UTC
So I made screenshots to show what I mean (now I used the 7.1.0.0.alpha0+ version). So I try now to show steps to reproduce in more detail:

1. launch Calc
2. save an empty spreadsheet
3. exit Calc
4. launch Calc again
5. load the previously made spreadsheet
6. resize a column with the cursor

after this, the lines for the print ranges appear in the spreadsheet like in the screenshot.
Comment 5 m.a.riosv 2020-10-23 09:39:43 UTC
By default, Menu/Tools/Options/LibreOffice calc/View - Visual aids - Page breaks it's enable. Disabling it and save and reload, doesn't show the lines.

IMO the bug here it's with it enable not showing the lines without save and reload.
Or the need to do something on the spreadsheet after one reload.
Comment 6 Dean3430 2020-10-23 10:53:47 UTC
(In reply to m.a.riosv from comment #5)
> By default, Menu/Tools/Options/LibreOffice calc/View - Visual aids - Page
> breaks it's enable. Disabling it and save and reload, doesn't show the lines.
> 
> IMO the bug here it's with it enable not showing the lines without save and
> reload.
> Or the need to do something on the spreadsheet after one reload.

Yes, I think you're right.
Comment 7 NISZ LibreOffice Team 2021-07-30 08:36:01 UTC
This was fixed in bug 124983. 
In upcoming 7.2 release page break lines will be visible by default when a file is opened.

*** This bug has been marked as a duplicate of bug 124983 ***