Bug 137778 - Sidebar element positioning becomes vertically cramped when switching selection between shape and connector (Windows, kf5 and gen)
Summary: Sidebar element positioning becomes vertically cramped when switching selecti...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 137866 (view as bug list)
Depends on:
Blocks: Sidebar-Properties
  Show dependency treegraph
 
Reported: 2020-10-26 20:02 UTC by Buovjaga
Modified: 2022-11-09 19:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (8.85 KB, application/vnd.oasis.opendocument.graphics)
2020-10-26 20:02 UTC, Buovjaga
Details
Screenshot of weirdness (24.13 KB, image/png)
2020-10-26 20:02 UTC, Buovjaga
Details
no issue with master on windows (148.57 KB, image/png)
2020-10-27 08:56 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2020-10-26 20:02:23 UTC
Created attachment 166745 [details]
Example file

1. Open example file
2. Select one of the shapes
3. Select the connector

(Can be vice versa, selection starting from connector)

The elements in the Position and size section become vertically cramped, Keep ratio checkbox even overflows into partial hiding. This is somehow linked to expanding/contracting property sections.

This is not seen with GTK3.

The change to the layout in 7.1 is
https://git.libreoffice.org/core/commit/b9e3341178ffe62ab0fc054e7046f124eb975c38
tdf#136099 Sidebar position and size alignment update

However, even earlier one can observe that the bottom of the Position and size section overflows into hiding.

Adding Cc: to Andreas Kainz

Not sure, if Andreas has an idea about this or if we need to ask for reinforcements.

Áron found this originally.
Comment 1 Buovjaga 2020-10-26 20:02:54 UTC
Created attachment 166746 [details]
Screenshot of weirdness
Comment 2 andreas_k 2020-10-27 08:30:27 UTC
I think it's part of the "old" bug that the resizing didn't work propper and part of the Position section was cutted.

which backend do you use? On Windows I don't have this issue with master.
Comment 3 Buovjaga 2020-10-27 08:43:14 UTC
(In reply to andreas_k from comment #2)
> I think it's part of the "old" bug that the resizing didn't work propper and
> part of the Position section was cutted.
> 
> which backend do you use? On Windows I don't have this issue with master.

Are you able to find the old report? I tried searching yesterday, but no luck.

I repro with a fresh master on Win

Version: 7.1.0.0.alpha1+ (x64)
Build ID: b61bf7c7cfcf97a5ade6d130873af146670bc2ee
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded
Comment 4 andreas_k 2020-10-27 08:56:58 UTC
Created attachment 166760 [details]
no issue with master on windows

no issue with master from 22.10.2020

Version: 7.1.0.0.alpha0+ (x64)
Build ID: abb5b9b367c21166c3c366fe88351d6ef3a4659c
CPU threads: 8; OS: Windows 10.0 Build 16299; UI render: Skia/Raster; VCL: win
Locale: de-AT (de_AT); UI: de-DE
Calc: threaded
Comment 5 andreas_k 2020-10-27 09:07:14 UTC
no issue with master from today (27.10.20) on windows.

At the Schreenshot of weirdness it look like the gen backend was used.
Comment 6 Aron Budea 2020-10-27 09:15:59 UTC
(In reply to andreas_k from comment #5)
> no issue with master from today (27.10.20) on windows.
> 
> At the Schreenshot of weirdness it look like the gen backend was used.
Have you clicked directly on one object after the other? It can also be reproduced by inserting two shapes, eg. rectangles in an empty sheet, and clicking on one, then on the other.
Comment 7 Aron Budea 2020-11-07 01:31:45 UTC
*** Bug 137866 has been marked as a duplicate of this bug. ***
Comment 8 QA Administrators 2022-11-08 03:48:11 UTC Comment hidden (obsolete)
Comment 9 Roman Kuznetsov 2022-11-09 19:44:00 UTC
No repro on Windows 10 in

Version: 7.5.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: ddb8a1a282aae74c1cee3a5e1f446abd0c00b116
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded

and I tried in KDE in the same build - no repro too

Buovjaga, please retest it yourself
Comment 10 Buovjaga 2022-11-09 19:57:19 UTC
Happy times, it's gone

Arch Linux 64-bit
Version: 7.5.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: b57307e8f3553fcb292c9c11fcf58bcef3a6cb3c
CPU threads: 8; OS: Linux 6.0; UI render: default; VCL: gen
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 8 November 2022