Bug 137810 - You cannot rename Character Style applied in Chapter Numbering
Summary: You cannot rename Character Style applied in Chapter Numbering
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.7.2 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard: target:7.2.0 target:7.1.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Chapter-Numbering
  Show dependency treegraph
 
Reported: 2020-10-28 03:01 UTC by John
Modified: 2021-05-18 10:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test ODT from step 5 (8.42 KB, application/vnd.oasis.opendocument.text)
2020-11-03 09:54 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John 2020-10-28 03:01:11 UTC
Description:
Steps:

1. Open new document, create character style "red" for red text
2. Tools > Chapter Numbering > Add numbering to the 1st level
3. In field "Character style" select "red"
4. Click OK button.
5. Type "foo", apply "Heading 1" style, so it will become "1 foo" where "1" is red.
5. Save and close document.

6. Open it again.
7. Rename "red" to "redaaa"
8. Save and close document.

9. Open document again. You will see that "1" is black. This is a bug.

You could try to fix it, but it won't work.

10. Open Tools > Chapter Numbering > In field "Character style" select "redaaa"
11. Save document, close it, open it again. The numbering is still black.

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Uwe Auer 2020-10-28 12:49:28 UTC
Can't repro in

Version: 6.4.7.2,Build ID: 639b8ac485750d5696d7590a72ef1b496725cfb5
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US, Calc: threaded
Comment 2 Timur 2020-11-03 09:54:50 UTC
Created attachment 166965 [details]
Test ODT from step 5

Repro LO 7.1+. 
Es explained, "redaaa" is added and "red" remained as Character Style in Chapter Numbering and stays there in step 9. and 11.
Comment 3 Timur 2020-11-03 10:16:37 UTC
Bibisect 64 Linux:

commit 62850234fe7a9cdc5819a3912c1b7c8c308909ff
Date:   Wed May 13 23:44:22 2020 +0200
    source sha:ae0e4a6ba9be2fa99ac2be8e20157806e36209b2
    previous source sha:8ccb18b7e35a4b8f733ecd2b6d12e075410d0468
Comment 4 Timur 2020-11-03 12:29:10 UTC
author	Vasily Melenchuk <vasily.melenchuk@cib.de>	2020-05-07 21:28:12 +0300
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2020-05-13 10:59:12 +0200
commit	ae0e4a6ba9be2fa99ac2be8e20157806e36209b2 (patch)
tree	1b69faba104672bbca7ae20f8e9c3a39ff03760d
parent	8ccb18b7e35a4b8f733ecd2b6d12e075410d0468 (diff)
tdf#94628: sw: allow setting for bullet for outline paragraphs
Paragraphs in outline (having style "Header XXX") can also be
a part of list and have custom bullets.

Simplified code of SwXNumberingRules::SetPropertiesToNumFormat():
do not check for properties special for outline/chapters and removed
redundant data shuffle with local maps.

CC Vasily, please take a look.
Comment 5 Commit Notification 2021-05-12 17:19:17 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c5e5467f6a13aba68b4706a4d7feb130e824bcc6

tdf#137810 sw: fix SwXNumberingRules setting CharStyleName

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Michael Stahl (allotropia) 2021-05-12 17:19:51 UTC
looks like same bug as https://bz.apache.org/ooo/show_bug.cgi?id=51842

fixed on master
Comment 7 Commit Notification 2021-05-18 08:54:16 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/2a71eac9027b3838f675ad20c91320abca8bb884

tdf#137810 sw: fix SwXNumberingRules setting CharStyleName

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Timur 2021-05-18 10:55:04 UTC
Verified. Thanks.