Bug 137907 - Wrong orientation of CJK Black Lenticular Brackets in vertical layout (AR PL UKai TW)
Summary: Wrong orientation of CJK Black Lenticular Brackets in vertical layout (AR PL ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK Vertical-Text Skia
  Show dependency treegraph
 
Reported: 2020-11-01 14:45 UTC by Volga
Modified: 2021-09-27 14:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample File (11.08 KB, application/vnd.oasis.opendocument.text)
2020-11-01 14:47 UTC, Volga
Details
My screenshot (90.51 KB, image/png)
2020-11-02 07:17 UTC, Volga
Details
Screenshot from LO 7.1 on Windows 10 (26.63 KB, image/png)
2020-11-03 20:16 UTC, Regina Henschel
Details
Font file from original source (9.86 MB, application/x-gzip)
2020-11-06 23:48 UTC, Volga
Details
Screenshot after disabling Skia (146.34 KB, image/png)
2020-11-13 14:45 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2020-11-01 14:45:24 UTC
Description:
While the AR PL UKai fonts used in the document, and set the vertical layout for the content, the CJK Black Lenticular Brackets (U+3010/3011) looks upright instead of rotate.

The fonts were found at https://web.archive.org/web/20160404044952/http://archive.ubuntu.com/ubuntu/pool/main/t/ttf-arphic-ukai/ttf-arphic-ukai_0.2.20080216.1.orig.tar.gz

Steps to Reproduce:
1. Download and install AR PL UKai fonts from above source
2. Open my attachment

Actual Results:
As explained above

Expected Results:
These characters should be rotated until the fonts has vertical from prepared for them.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: zh-CN (zh_CN); 界面: zh-CN
Calc: threaded
Comment 1 Volga 2020-11-01 14:47:48 UTC
Created attachment 166906 [details]
Sample File
Comment 2 Volga 2020-11-02 07:17:57 UTC
Created attachment 166915 [details]
My screenshot
Comment 3 Regina Henschel 2020-11-03 20:16:04 UTC
Created attachment 166980 [details]
Screenshot from LO 7.1 on Windows 10

For me the brackets are turned. However, I did not install the original font, so a replacement font is used.
Comment 4 Volga 2020-11-04 13:01:12 UTC
(In reply to Regina Henschel from comment #3)
> Created attachment 166980 [details]
> Screenshot from LO 7.1 on Windows 10
> 
> For me the brackets are turned. However, I did not install the original
> font, so a replacement font is used.
Yes, me too. So what happened if you get the original font.
Comment 5 Regina Henschel 2020-11-04 16:47:39 UTC
(In reply to Volga from comment #4)
> Yes, me too. So what happened if you get the original font.

It is OK with original font too.

I use Version: 7.1.0.0.alpha1+ (x64)
Build ID: a689cf1672e89cb78fbcfa14c505850927e71f58
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL
Comment 6 Ming Hua 2020-11-05 18:42:03 UTC
I'm also getting correct (rotated) brackets with AR PL UKai TW fonts installed, with 6.4.7 on Windows 10.  I can't access the web.archive.org link in comment 0, I got the font from Debian archive of old versions instead.

The font is the same version (0.2.20080216.1) as in the link, and the font file is 17,151,049 bytes, with SHA-1 checksum 24C67A004A624621CFC6A2CD1A49EBDB21525097.

Version: 6.4.7.2 (x64)
Build ID: 639b8ac485750d5696d7590a72ef1b496725cfb5
CPU threads: 2; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: zh-CN (zh_CN); UI-Language: en-US
Calc: threaded
Comment 7 Volga 2020-11-06 23:48:38 UTC
Created attachment 167069 [details]
Font file from original source
Comment 8 Volga 2020-11-07 00:42:17 UTC
I used Windows 10 Home China Edition, I don't know whether that version affect me. You can download from here, and install into a virtual machine:
https://www.microsoft.com/zh-cn/software-download/windows10ISO
If you are using Windows 10 now, you need to use some browser extensions such as User Agent Switcher and Manager to modifythe user-agent string. 

After openning the URL:
1. Click 选择版本 (select edition), to choose Windows 10 家庭中文版, click 确认 (confirm)
2. Find out 选择产品语言 (Select the product language), choose 简体中文 (Chinese Simplified), then click 确认 (confirm)
Then you'll get two links for ISO package, available as 64-bit and 32-bit.
Comment 9 Volga 2020-11-08 09:42:51 UTC
(In reply to Volga from comment #7)
> Created attachment 167069 [details]
> Font file from original source
I checked the font file and the SHA-1 checksum is the same as comment 6. That's strange.
Comment 10 Ming Hua 2020-11-08 10:42:33 UTC
(In reply to Volga from comment #9)
> I checked the font file and the SHA-1 checksum is the same as comment 6.
> That's strange.
Have you tried turning off Skia?  Both Regina and I were using default rendering.
Comment 11 Volga 2020-11-13 12:59:47 UTC
(In reply to Ming Hua from comment #10)
> (In reply to Volga from comment #9)
> > I checked the font file and the SHA-1 checksum is the same as comment 6.
> > That's strange.
> Have you tried turning off Skia?  Both Regina and I were using default
> rendering.
Oh, how can I do this?
Comment 12 Ming Hua 2020-11-13 13:28:31 UTC
(In reply to Volga from comment #11)
> (In reply to Ming Hua from comment #10)
> > Have you tried turning off Skia?  Both Regina and I were using default
> > rendering.
> 
> Oh, how can I do this?
Tools > Options > LibreOffice > View, uncheck "Use Skia for all rendering" (or something like that, I'm on 6.4.7 right now and can't check the exact wording).
Comment 13 Volga 2020-11-13 14:45:01 UTC
Created attachment 167277 [details]
Screenshot after disabling Skia

Oh yeah, it’s works for me. So there should be something missing for Skia backend.
Comment 14 Ming Hua 2020-11-13 17:21:09 UTC
(In reply to Volga from comment #13)
> Oh yeah, it’s works for me. So there should be something missing for Skia
> backend.
Not surprising.  Skia is known to have issues with vertical CJ(K?) text, see bug 136081.
Comment 15 Ming Hua 2020-12-02 23:37:28 UTC
Reproduced in 7.1.0 Beta1:

Good (rotated brackets) in:
Version: 7.1.0.0.beta1 (x64)
Build ID: 828a45a14a0b954e0e539f5a9a10ca31c81d8f53
CPU threads: 2; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: zh-CN (zh_CN); UI: zh-CN
Calc: threaded

... and bad (not rotated) in:
Version: 7.1.0.0.beta1 (x64)
Build ID: 828a45a14a0b954e0e539f5a9a10ca31c81d8f53
CPU threads: 2; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: zh-CN (zh_CN); UI: zh-CN
Calc: threaded
Comment 16 Luboš Luňák 2021-05-24 09:08:15 UTC
This should be fixed for 7.2+. As the fixes depend on other changes that are non-trivial and will not be backported to 7.1, this issue can be worked around by disabling Skia for 7.1 until 7.2 is released.
Comment 17 Ming Hua 2021-06-18 15:29:40 UTC
Confirmed with 7.2.0 Beta1 on Windows 10:
Version: 7.2.0.0.beta1 (x64) / LibreOffice Community
Build ID: c6974f7afec4cd5195617ae48c6ef9aacfe85ddd
CPU threads: 2; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: zh-CN (zh_CN); UI: zh-CN
Calc: threaded

Thanks Luboš!