Bug 137945 - Every time after spreadsheet saved and reopened, spaces are multiplied in content validation help messages
Summary: Every time after spreadsheet saved and reopened, spaces are multiplied in con...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:7.0.7 target:7.2....
Keywords: bibisected, bisected, dataLoss, regression
: 141940 (view as bug list)
Depends on:
Blocks: Cell-Validity
  Show dependency treegraph
 
Reported: 2020-11-02 18:40 UTC by Rohonczi Gyula
Modified: 2021-06-11 04:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
first save of the file (10.68 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-11-02 18:44 UTC, Rohonczi Gyula
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rohonczi Gyula 2020-11-02 18:40:14 UTC
Description:
I used spaces for order the cell's help message text into columns.
But it's gone wrong from the 7.0.0 LO.


Steps to Reproduce:
1. do a content-validation format with many spaces
2. save the file
3. reopen it, and the counts of spaces are more

Actual Results:
reproduced the fail

Expected Results:
counts of spaces is the original


Reproducible: Always


User Profile Reset: No



Additional Info:
I found this in the ods file's content.xml file:
table:content-validation / table:help-message / text:s / text:c value was incredible large number. (but only here, in the table section not)
Comment 1 Rohonczi Gyula 2020-11-02 18:44:36 UTC
Created attachment 166952 [details]
first save of the file

I add spaces like the number before, but there are more spaces than the original.
Comment 2 Aron Budea 2021-04-29 03:00:23 UTC
This indeed regressed in 7.0, and is already fixed in 7.1. The regressing and fixing commits respectively are:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ae854970bf9c734df132797c0f23a7829efd167c
author		Noel Grandin <noel.grandin@collabora.co.uk>	2020-03-05 12:40:57 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2020-03-06 08:09:04 +0100

"use more FastParser in ScXMLContentValidationContext"

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8c5ffecf1dbd3f93128910433da11d5315661680
author		Noel <noelgrandin@gmail.com>	2020-10-23 15:12:22 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2020-11-02 08:17:00 +0100

"make SvXMLImport capable of mixing fast- and slow- contexts adhoc"

Not sure what to do about this in 7.0... perhaps the simplest would be to revert the regressing commit in 7.0? It seems problematic to leave it in.
Noel, Xisco, what are your thoughts?
Comment 3 Xisco Faulí 2021-04-29 07:38:00 UTC
Hi Aron,
Thanks for the great analysis. Revert proposal for libreoffice-7-0 branch done in https://gerrit.libreoffice.org/c/core/+/114833
Comment 4 Commit Notification 2021-04-29 18:44:00 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/6ac038c54121ec307ed75f8fb45f591cca9f8519

tdf#137945: Revert "use more FastParser in ScXMLContentValidationContext"

It will be available in 7.0.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2021-04-29 19:48:58 UTC
Verified in

Version: 7.0.7.0.0+
Build ID: 6ac038c54121ec307ed75f8fb45f591cca9f8519
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 6 Aron Budea 2021-04-29 20:37:00 UTC
*** Bug 141940 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2021-04-30 14:00:28 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b9097800f4f997de2325bc9e588e6caea7a563c7

tdf#137945: sc: Add UItest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2021-04-30 14:01:41 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/c0380b0f52e4ad03f98745cbc24395d33bc2d305

tdf#137945: sc: Add UItest

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2021-04-30 15:59:08 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/c976a18758b77ab989f3cc1a34623ff403651801

tdf#137945: sc: Add UItest

It will be available in 7.0.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-05-05 17:42:11 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-0-6":

https://git.libreoffice.org/core/commit/11332f543a2ecd1a83066d49c040f2b51cbccc97

tdf#137945: Revert "use more FastParser in ScXMLContentValidationContext"

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 matchstickman 2021-05-24 10:53:44 UTC
Tested the stable download of 7.0.6.2. Issue now seems to be resolved in this version. Good work Xisco. Thanks.
Comment 12 talleychan 2021-06-11 04:23:22 UTC
Hello, Aron.
Thank you for your thorough study. Revert the suggestion made for the LibreOffice-7-0 branch https://2player.co/
It will be included in version 7.0.7.
Users who have been affected are invited to try out the update and provide feedback.