Download it now!
Bug 137949 - IMPORT OOXML: Table row height is wrong.
Summary: IMPORT OOXML: Table row height is wrong.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Gülşah Köse
URL:
Whiteboard: target:7.1.0 target:7.0.4
Keywords: bibisected, bisected, regression
: 135601 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-02 20:42 UTC by Gülşah Köse
Modified: 2020-11-19 16:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (43.56 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-11-02 20:43 UTC, Gülşah Köse
Details
Comparison LibreOffice 7.1 master and MSO 2010 (49.45 KB, image/png)
2020-11-03 09:16 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gülşah Köse 2020-11-02 20:42:52 UTC
Description:
Table and row heights are different.

Steps to Reproduce:
1.Open sample.pptx

Actual Results:
Table height is bigger than actual. Row heights are not equal.

Expected Results:
Table height should be smaller, Row heights should be equal


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Gülşah Köse 2020-11-02 20:43:32 UTC
Created attachment 166954 [details]
sample
Comment 2 Xisco Faulí 2020-11-03 09:16:47 UTC
Created attachment 166964 [details]
Comparison LibreOffice 7.1 master and  MSO 2010
Comment 3 Xisco Faulí 2020-11-03 09:38:37 UTC
this is a regression from my commit

author	Xisco Fauli <anistenis@gmail.com>	2016-01-21 20:56:31 +0100
committer	jan iversen <jani@documentfoundation.org>	2016-01-30 07:40:22 +0000
commit	13d4398820ded5914f635757865e258db2db2b57 (patch)
tree	356431bab06546113e07462070948388e3d6fc6e
parent	2416a2965f4d51e1b14b8539436f5f8fc16cc399 (diff)
tdf#91762: Check wether the row and the cell have text...

Bisected with: bibisect-linux-64-5.2
Comment 4 Gülşah Köse 2020-11-03 10:27:14 UTC
Hi Xisco, Can you review the patch when you have time? https://gerrit.libreoffice.org/c/core/+/105228
Comment 5 Commit Notification 2020-11-04 21:48:52 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7dc234fa57ca409d0db131c93abea738014b5e1f

tdf#137949 Fix table row heigths.

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-11-05 10:33:10 UTC
Verified in

Version: 7.1.0.0.alpha1+
Build ID: 9c8ed8c8526b9b696d0bf592eb7d963950f3cef4
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Gülşah Köse, thanks for fixing this issue!!
Comment 7 Gülşah Köse 2020-11-05 11:03:57 UTC
Thanks for the review Xisco o/
Comment 8 Commit Notification 2020-11-05 16:44:45 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/54daa022df46d07171201b3fe236cf3f5726e271

tdf#138011: Revert "tdf#137949 Fix table row heigths."

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2020-11-05 16:46:01 UTC
Commit reverted, reopening
Comment 10 Commit Notification 2020-11-09 11:36:56 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b7b05dd36403af50b20fe06cbf8a10d8defb28a9

tdf#137949 Fix table row heigths.

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2020-11-09 14:10:15 UTC
*** Bug 135601 has been marked as a duplicate of this bug. ***
Comment 12 Commit Notification 2020-11-09 14:36:37 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/5c37f0c0347d8cccda6fc6a2ca4dd28bb36823a9

tdf#137949 Fix table row heigths.

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.