Bug 137985 - Fileopen DOCX: Header text from table not visible
Summary: Fileopen DOCX: Header text from table not visible
Status: RESOLVED DUPLICATE of bug 107055
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks:
 
Reported: 2020-11-04 14:47 UTC by Timur
Modified: 2020-11-04 15:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample DOCX compared in MSO and LO (277.79 KB, image/png)
2020-11-04 14:47 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2020-11-04 14:47:50 UTC
Created attachment 167001 [details]
Sample DOCX compared in MSO and LO

Open DOCX attachment 81684 [details] from bug 81522 and see that header text is missing. 
OK in LO 5.3, NOK in 5.4.

attachment 81684 [details] is well-known trouble DOCX, seen in more bugs. 
It's 2007 but regardless, same if resaved in MSO as DOCX.
Also DOC variant was at least in bug 66119 and bug 115649.
Comment 1 Timur 2020-11-04 15:09:15 UTC
Bibisect 5.4 Lin, single commit:

commit 842f510528624a3ae2f98fa99fe3f67d45dad4df
Date:   Fri Mar 31 17:40:26 2017 +0200
    source sha:38b0c24fa5cbb4246e03d77ac022dfdc9fdede03
    prev sha:a82627aa787e80c9473453acd5ec955b6cf265ff

author	Miklos Vajna <vmiklos@collabora.co.uk>	2017-03-30 09:27:45 +0200
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-03-30 10:19:02 +0000
commit	38b0c24fa5cbb4246e03d77ac022dfdc9fdede03 (patch)
tree	6c500a9f343126a28508aaa2adc581d819a2eb96
parent	a82627aa787e80c9473453acd5ec955b6cf265ff (diff)
Related: tdf#105454 DOCX import: fix unwanted enabled-by-default kerning
Similar to DOC, DOCX doesn't enable kerning by default.

Miklos, this is accidentally the same file of today, but different regression.
Comment 2 Xisco Faulí 2020-11-04 15:12:43 UTC
already reported in bug 107055

*** This bug has been marked as a duplicate of bug 107055 ***
Comment 3 Timur 2020-11-04 15:19:12 UTC
Thanks. 
With repetitive tasks, something can be omitted, like check of duplicate. 
AI automated testing will supposedly be more precise.