Bug 138006 - Is there a reason why it isn't possible to mark/select the pilcrow/paragraph mark?
Summary: Is there a reason why it isn't possible to mark/select the pilcrow/paragraph ...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-11-05 09:21 UTC by canned
Modified: 2020-11-13 16:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Autotext Example (9.46 KB, application/vnd.oasis.opendocument.text)
2020-11-09 11:59 UTC, canned
Details

Note You need to log in before you can comment on or make changes to this bug.
Description canned 2020-11-05 09:21:48 UTC
Description:
Is there a reason why it isn't possible to mark/select the pilcrow/paragraph mark?

When inserting autotext, it would sometimes be easier if you could mark the paragraph tag, because otherwise you would have to work with superfluous blank lines or spaces, which have to be deleted manually after inserting the autotext (e.g. frame element as autotext).

Actual Results:
When inserting Autotext, superfluous blank lines and spaces may occur in certain cases (e.g. frame element as autotext)

Expected Results:
There would be no superfluous blank lines and spaces when inserting autotext (e.g. frame element as autotext)


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded
Comment 1 V Stuart Foote 2020-11-05 23:09:58 UTC
(In reply to canned from comment #0)
>...
> Is there a reason why it isn't possible to mark/select the pilcrow/paragraph
> mark?
> ...

Because it is a 'visual' decoration applied to the document canvas.  

There is no Pilcrow glyph embedded into the document to search for/select, just the end of paragraph object(s) which can be searched for--the '$'

It symbolizes the 'end of paragraph object'--CH_PAR--which are notated in LibreOffice's ICU search [1]. 

As to working with Autotext, not following the workflow--please attach a sample document and clear steps to reproduce what perceived issue is.

=-refs-=
[1] https://unicode-org.github.io/icu/userguide/strings/regexp.html
Comment 2 canned 2020-11-06 08:45:11 UTC
(In reply to V Stuart Foote from comment #1)
> (In reply to canned from comment #0)
> >...
> > Is there a reason why it isn't possible to mark/select the pilcrow/paragraph
> > mark?
> > ...
> 
> Because it is a 'visual' decoration applied to the document canvas.  
> 
> There is no Pilcrow glyph embedded into the document to search for/select,
> just the end of paragraph object(s) which can be searched for--the '$'
> 
> It symbolizes the 'end of paragraph object'--CH_PAR--which are notated in
> LibreOffice's ICU search [1]. 
> 
> As to working with Autotext, not following the workflow--please attach a
> sample document and clear steps to reproduce what perceived issue is.
> 
> =-refs-=
> [1] https://unicode-org.github.io/icu/userguide/strings/regexp.html



Wouldn't it be elegant to combine a "decorative" element with a useful function?

Autotext example:
Open a new document and try to create a text frame (Insert > Frame > Frame) as autotext. For me, this only works if I insert an empty space in the line. I have to mark this empty space, so that the text frame is also marked, to save it as autotext. If I insert the autotext after that, I have to delete the empty space again and again. 
If you rarely insert such autotexts, this is not a problem, but when I am working on a complex, multifaceted document, it is very tedious. 
If the pilcrow glyph were selectable, I could use it to select the text frame (without using an unnecessary empty space as a tool) to save the autotext.
Comment 3 V Stuart Foote 2020-11-06 14:50:24 UTC
Sorry, still not following the desired work flow. 

You are using the Frame... dialog to create as a frame place holder for Autotext... (<Ctrl>+F3) dialog content, and then making edits/reusing the resulting Frame and any Autotext--with a copy and paste?

Sample doc, screen clip, or a screen cast of what you are asking.

Thanks.
Comment 4 canned 2020-11-09 11:59:14 UTC
Created attachment 167128 [details]
Autotext Example

Try to create an autotext from this frame-element. There’s no way to select it without using an empty space or an empty line.
Comment 5 Michael Stahl (allotropia) 2020-11-13 08:30:32 UTC
(In reply to V Stuart Foote from comment #1)
> (In reply to canned from comment #0)
> >...
> > Is there a reason why it isn't possible to mark/select the pilcrow/paragraph
> > mark?
> > ...
> 
> Because it is a 'visual' decoration applied to the document canvas.  
> 
> There is no Pilcrow glyph embedded into the document to search for/select,
> just the end of paragraph object(s) which can be searched for--the '$'

yes, that's the reason. in Word, it is an actual character that can have formatting applied to it, but not in Writer, here it's just painted where the end of the paragraph is.
Comment 6 Heiko Tietze 2020-11-13 16:11:31 UTC
(In reply to canned from comment #0)
> Is there a reason...

(In reply to Michael Stahl (CIB) from comment #5)
> yes, that's the reason.

So actually NAB but WF since enhancement.
Comment 7 V Stuart Foote 2020-11-13 16:58:39 UTC
OK, but I still can't get my head around the workflow the OP is looking to accomplish for Autotext held in a frame/or Text box.