Bug 138065 - UI: Favorite characters in special character dialog & drop down pick box to small
Summary: UI: Favorite characters in special character dialog & drop down pick box to s...
Status: RESOLVED DUPLICATE of bug 115634
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-08 09:33 UTC by Telesto
Modified: 2022-10-03 19:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Special Character dialog recents and favorites bars not scaled (to 250%) with rest of the dialog (154.92 KB, image/png)
2020-11-08 16:30 UTC, V Stuart Foote
Details
Screenshot (39.04 KB, image/jpeg)
2020-11-08 19:07 UTC, Telesto
Details
Screenshot (31.41 KB, image/jpeg)
2021-08-31 16:45 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-11-08 09:33:41 UTC
Description:
Favorite characters in special character dialog & drop down pick box to small

Steps to Reproduce:
1. Open Writer
2. Click they special character drop down

Actual Results:
Small tiny previews (also in special character dialog itself)

Expected Results:
Large previews like 6.3 (for drop down). It was smaller in they special character dialog all the time.. they picker is larger compared to Recent list/ Favorites


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha1+ (x64)
Build ID: 5a96093f0ecee53432bdf35f247edd6deb501baf
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 V Stuart Foote 2020-11-08 16:09:03 UTC
What screen resolution and scale factor is in use?
Comment 2 V Stuart Foote 2020-11-08 16:30:22 UTC
Created attachment 167099 [details]
Special Character dialog recents and favorites bars not scaled (to 250%) with rest of the dialog

I can reproduce this with a UI scaling set to 250%, skia Vulkan or Raster.

Depending on OPs response, believe this is a duplicate of bug 128243, the 'recents' and 'favorites' picker bars of the Special Character dialog are another UI element that are not correctly handed for scaling. Similar to the color picker dialog.

=-testing=-=
Version: 7.1.0.0.alpha1+ (x64)
Build ID: 5a96093f0ecee53432bdf35f247edd6deb501baf
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 3 V Stuart Foote 2020-11-08 16:48:16 UTC
(In reply to V Stuart Foote from comment #2)
> another UI element that are not correctly handed for scaling. Similar to the
> color picker dialog.

color picker dialog's icons.
Comment 4 Telesto 2020-11-08 19:07:45 UTC
Created attachment 167102 [details]
Screenshot
Comment 5 Abhi 2020-12-07 01:19:45 UTC
Thanks for reporting this bug. I was unable to reproduce it in:

Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 16; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

and

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 5f665a855ef26fae4dfa2ac427685b60545e8b8
CPU threads: 16; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 6 Buovjaga 2021-08-31 15:23:14 UTC
As bug 128243 was marked as worksforme, can you re-test?
Comment 7 Telesto 2021-08-31 16:45:29 UTC
Created attachment 174680 [details]
Screenshot

Still small, see screenshot (6.2 vs 7.3)
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 05ff3d67d0e2e436406786c949eb7cfca107ba33
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 8 Telesto 2021-08-31 16:46:49 UTC
FWIW, I don't use scaling.
Comment 9 Buovjaga 2021-08-31 17:35:43 UTC
Ok I confirm, but I guess it's more a matter of taste, so pinging UX. I wouldn't call them tiny.

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: a866d63e0ac9de4ff7e59b3928f09ec21877bef3
CPU threads: 2; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded Jumbo
Comment 10 Heiko Tietze 2021-09-01 08:53:54 UTC
(In reply to V Stuart Foote from comment #2)
> I can reproduce this with a UI scaling set to 250%, skia Vulkan or Raster.
This is a bug
 
> Depending on OPs response, believe this is a duplicate of bug 128243...
If solved, WFM? Stuart, please retest.
Comment 11 Buovjaga 2021-09-01 10:02:02 UTC
(In reply to Heiko Tietze from comment #10)
> (In reply to V Stuart Foote from comment #2)
> > I can reproduce this with a UI scaling set to 250%, skia Vulkan or Raster.
> This is a bug
>  
> > Depending on OPs response, believe this is a duplicate of bug 128243...
> If solved, WFM? Stuart, please retest.

No, Telesto doesn't use scaling :)
Comment 12 Heiko Tietze 2021-09-13 10:40:03 UTC
(In reply to Buovjaga from comment #11)
> No, Telesto doesn't use scaling :)

In this case: no repro.

Otherwise WFM or bug.
Comment 13 V Stuart Foote 2022-10-03 19:41:44 UTC

*** This bug has been marked as a duplicate of bug 115634 ***