Bug 138082 - Merged Cells adopt the format of the first cell instead of the cell with contents
Summary: Merged Cells adopt the format of the first cell instead of the cell with cont...
Status: RESOLVED DUPLICATE of bug 89951
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.6.2 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Merge-Split
  Show dependency treegraph
 
Reported: 2020-11-09 06:55 UTC by Colin
Modified: 2020-11-09 09:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
What a similar file looks like in Excel and Calc before merging cells (50.95 KB, image/png)
2020-11-09 08:24 UTC, NISZ LibreOffice Team
Details
What a similar file looks like in Excel and Calc after merging cells (47.56 KB, image/png)
2020-11-09 08:24 UTC, NISZ LibreOffice Team
Details
Example file to reproduce the problem (10.17 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-11-09 08:26 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin 2020-11-09 06:55:00 UTC
Version: 6.4.6.2 (x64)
Build ID: 0ce51a4fd21bff07a5c061082cc82c5ed232f115
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win; 
Locale: sv-SE (en_GB); UI-Language: en-GB
Calc: threaded

If a small array of say three horizontal cells contains formatted data ONLY in the centre cell then selecting the two adjacent cells to [Merge & Centre Cells] with the "filled" cell adopts the format of the first cell in the selected range and ignores the format implied by the only data contained in the selected range.

1 Type in any empty cell "Lucida 16pt"
2 Select that cell and change the format to Lucida Handwriting 16pt
3 Select the range including the adjacent cell on either side and [Merge & Centre Cells]
4 Observe that the format reverts to whatever is the format of the first cell in the range
5 With the range selected, access the font menu with the down chevron and the Lucida font will magically identify itself as the cell format and the displayed format will change to Lucida - but only until the chevron is released
6 Expunge the [Merge & Centre Cells] format and the contents jump into the first cell of the range and revert to default format.

The same effect is apparent with a vertically adjacent range of cells.
The same effect is apparent if the "filled" cell is at either extremity of the [Merge & Centre Cells] range
If two cells contain data then the merge rules are handled correctly BUT all cells will adopt the "first cell" format. This is the Dichotomy - How should two alternate formats be treated? It's only a conundrum if more than two formats exist ;)))
Comment 1 NISZ LibreOffice Team 2020-11-09 08:16:52 UTC
Repro with:

Version: 7.1.0.0.alpha1+ (x64)
Build ID: a4d4ed86991e2901ac86189e95966d4e99be4944
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 2 NISZ LibreOffice Team 2020-11-09 08:24:30 UTC
Created attachment 167110 [details]
What a similar file looks like in Excel and Calc before merging cells
Comment 3 NISZ LibreOffice Team 2020-11-09 08:24:51 UTC
Created attachment 167111 [details]
What a similar file looks like in Excel and Calc after merging cells
Comment 4 NISZ LibreOffice Team 2020-11-09 08:26:06 UTC
Created attachment 167112 [details]
Example file to reproduce the problem
Comment 5 Timur 2020-11-09 08:30:55 UTC
Looks duplicate.
This report is better but let's appreciate former report and search before posting.

*** This bug has been marked as a duplicate of bug 89951 ***
Comment 6 Colin 2020-11-09 08:43:58 UTC
(In reply to Timur from comment #5)
> Looks duplicate.
> This report is better but let's appreciate former report and search before
> posting.
> 
> *** This bug has been marked as a duplicate of bug 89951 ***

Not quite sure what route I took* but my search for "Merged Cell Format" returned about five reports - none of which were relevant.
* Sometimes I go in through Bugzilla and sometiimes through the feedback in Help. Sometimes I'm already "logged in" and other occasions require login.
On this occasion, the presented page was not what I was accustomed to so after having formulated my query with little relevance I then exited and re-entered via the Feedback process simply to file what appeared to be a unique report.
Sorry -It Happens
Comment 7 Timur 2020-11-09 08:46:15 UTC
I get 106 reports with same words, without quote, at https://bugs.documentfoundation.org/query.cgi
I guess it's the quote.
Comment 8 Colin 2020-11-09 08:58:04 UTC
(In reply to Timur from comment #7)
> I get 106 reports with same words, without quote, at
> https://bugs.documentfoundation.org/query.cgi
> I guess it's the quote.

Afterthe enquiry I ended up here  https://bugs.documentfoundation.org/enter_bug.cgi?product=LibreOffice

Which looked "odd" Also, it doesn't offer the additional Panes for steps to produce etc.

Not attempting to abnegate responsibility for a duplicate report but it might indicate some inconsistencies in the reporting process.
Comment 9 Timur 2020-11-09 09:14:51 UTC
That link is for reporting bugs. 
On typing a title it offers some possible duplicates. 
But search should be done before and it gives a lot of bugs, including original report. 
I know that people complain sometimes that search didn't yield previous report for them, but I don't know how they searched, when "Search" on top gives good results.
Comment 10 Colin 2020-11-09 09:32:49 UTC
(In reply to Timur from comment #9)
> That link is for reporting bugs. 
> On typing a title it offers some possible duplicates. 
> But search should be done before and it gives a lot of bugs, including
> original report. 
> I know that people complain sometimes that search didn't yield previous
> report for them, but I don't know how they searched, when "Search" on top
> gives good results.

Perhaps there are too many routes - ie Libre Help, Bugzilla Home page and email click on link to gain access, search and report.
Unfortunately, this allows a user to inadvertently miss or skip a stage.
It's unlikely to be intentional as most users reporting an anomaly will be motivatied by the desire to help.
Some may even be under time constraints at that moment and then in too much of a hurry to recognise they missed something in between actually updating the sheet they were working on, trying to find a workaround and reporting it to a higher authority.
I do appreciate that all the resources are voluntary.