Bug 138115 - Cropped Images with Certain Text Wrappings on DOCX files do not Appear on Exported PDF
Summary: Cropped Images with Certain Text Wrappings on DOCX files do not Appear on Exp...
Status: RESOLVED DUPLICATE of bug 129085
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.6.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-11-10 15:34 UTC by jake.weilhammer
Modified: 2020-11-12 07:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Original Docx File with cropped images in "Tight" wrapping (95.68 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-11-10 15:35 UTC, jake.weilhammer
Details
Comparison of Original file on Word vs LibreOffice vs Exported PDF (660.71 KB, image/png)
2020-11-10 15:36 UTC, jake.weilhammer
Details
Exported PDF from LibreOffice of the original file (12.25 KB, application/pdf)
2020-11-10 15:37 UTC, jake.weilhammer
Details
Original file with Different Wrappings "Square" and "Top and Bottom" - Fixes issue (95.69 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-11-10 15:38 UTC, jake.weilhammer
Details
Comparison of file with different wrappings, Word vs Libre vs Exported PDF (739.90 KB, image/png)
2020-11-10 15:39 UTC, jake.weilhammer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jake.weilhammer 2020-11-10 15:34:08 UTC
Appears as though images that have been inserted and cropped with Microsoft Word and then have been given the "Tight" or "Through" text wrappings do not appear on the exported PDF when opened with LibreOffice.

The images sometimes appear on the document when opened with LibreOffice, but even if they do they do not appear on the exported PDF.


Changing the text wrapping to "Square", "In-line with Text", or "Top and Bottom" on Word seems to fix the problem and the images appear on the PDF generated by Libre.


To Crop image on Word, insert image and then go to Picture Format -> Crop, and make the image smaller than the original.
Comment 1 jake.weilhammer 2020-11-10 15:35:20 UTC
Created attachment 167171 [details]
Original Docx File with cropped images in "Tight" wrapping
Comment 2 jake.weilhammer 2020-11-10 15:36:13 UTC
Created attachment 167172 [details]
Comparison of Original file on Word vs LibreOffice vs Exported PDF
Comment 3 jake.weilhammer 2020-11-10 15:37:20 UTC
Created attachment 167173 [details]
Exported PDF from LibreOffice of the original file
Comment 4 jake.weilhammer 2020-11-10 15:38:14 UTC
Created attachment 167174 [details]
Original file with Different Wrappings "Square" and "Top and Bottom" - Fixes issue
Comment 5 jake.weilhammer 2020-11-10 15:39:27 UTC
Created attachment 167175 [details]
Comparison of file with different wrappings, Word vs Libre vs Exported PDF
Comment 6 Timur 2020-11-11 15:16:34 UTC
Repro 7.1+. Regression from 6.1. To be seen if duplicate.
Comment 7 Timur 2020-11-11 15:24:32 UTC
commit 2fef986f79c5fc901242a901ecc7ff1b698af0f0
Date:   Wed Apr 3 19:06:14 2019 +0200
    source c2ae30b19d8145271f1189c9757d59d43de391c7
    prev source 1dc8088162a66a99217dae3258711cbfa8f9bc28

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c2ae30b19d8145271f1189c9757d59d43de391c7

author	Armin Le Grand <Armin.Le.Grand@me.com>	2019-04-02 17:59:40 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2019-04-03 12:32:38 +0200
commit c2ae30b19d8145271f1189c9757d59d43de391c7 (patch)
tree eaed7ddd4b2327e71deccca512918d9d88765927
parent 1dc8088162a66a99217dae3258711cbfa8f9bc28 (diff)
tdf#124272 use ClipRegion's geometry if not a rectangle


Useless biibisect..I forgot bug 129085.

Jake, please search before submitting.

*** This bug has been marked as a duplicate of bug 129085 ***
Comment 8 jake.weilhammer 2020-11-11 17:56:43 UTC
Timur,

It doesn't seem to me like this is a duplicate of bug 129085, but maybe I am not fully understanding the logic behind that commit.

Testing out the file from bug 129085, it appears to be working properly on 7.0+ and on 6.4

The problem files from this bug do not seem to be working on 7.0 or 6.4. So I'm thinking that this may be a separate issue entirely.  Please let me know if you can test this out or if it is indeed a duplicate then I can follow that parent issue instead.

Thanks!
Comment 9 Timur 2020-11-12 07:49:47 UTC
Thanks for follow-up.
I'll stick with the duplicate, please see there.
Separate bug has worse chances and this is related, you made a good point with wrap, although Print and Export are not always the same.