Download it now!
Bug 138130 - Crash in: swlo.dll
Summary: Crash in: swlo.dll
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.0.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-11-11 10:50 UTC by Karl
Modified: 2020-12-02 10:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["swlo.dll"]


Attachments
Testfile mentioned in the description (8.77 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-11-11 10:50 UTC, Karl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karl 2020-11-11 10:50:50 UTC
Created attachment 167190 [details]
Testfile mentioned in the description

This bug was filed from the crash reporting server and is br-156bff30-1123-4f4c-9888-b7c80755005e.
=========================================

Writer crashes when trying to change the anchor of the textbox on page 2 (in the provided example file).

Steps for replicating: 
1) Open the file
2) Scroll to page 2 where you'll find a textbox with content "Beispiel 1"
3) Right-click on the textbox --> Anchor --> To Page

Writer crashes immediately. On one occasion which I couldn't replicate, an error message popped up with "bad dynamic cast".

When opening the file after the crash, Writer will also go into an infinite start-loop if document recovery is selected.

This might be a regression, didn't happen with the same document on LibreOffice 7.0 (I upgraded a few days ago).
Comment 1 Xisco Faulí 2020-11-11 12:43:21 UTC
I can't reproduce it in

Version: 7.0.2.0.0+
Build ID: b27137a7091104cce177791478e86d127680c9af
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

nor in

Version: 7.1.0.0.alpha1+
Build ID: 03cafc2ab6b1678f82e9a30b6f81e505660ee702
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

but I do in

Version: 7.0.3.1 (x86)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); Interfaz: es-ES
Calc: threaded
Comment 2 Karl 2020-11-14 20:30:53 UTC
I followed the guide for bibisecting and I hope that I haven't made any mistakes.
I used the bibisect repository linux64-7.0 (https://bibisect.libreoffice.org/linux-64-7.0)

Here's the result:

commit 45bb135c874d6333cfb0d4302225024f7284bb1f
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Wed Oct 21 20:39:22 2020 +0200

source sha:4e7b60682d48c7f3950e341c496dc7fc6f9b4367


Following the guide further, I searched for the commit in bugzilla and found this:
https://bugs.documentfoundation.org/show_bug.cgi?id=136385

It's related to the issue, so I installed the 7.0.4 daily build and tested it, but the issue persists in the Dev-Build.

I also added Caolán McNamara to CC as mentioned in the tutorial.

Sorry if I did something wrong, this is my first time trying to help an OpenSource project :)
Comment 3 Karl 2020-11-14 20:45:20 UTC
Edit: I think I added the wrong person. Author should be Michael Stahl, right?
Comment 4 Xisco Faulí 2020-11-16 12:22:19 UTC
Hi Karl,
Thanks for bisecting this issue.
I can't reproduce the crash in

Version: 7.1.0.0.alpha1+ (x64)
Build ID: c3f78d6b29579911606700f136796c150c4547c2
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-US
Calc: threaded
Comment 5 Commit Notification 2020-11-25 17:09:00 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/92f1c430e4e77e71e7c914ad567d4970e5b2cd95

tdf#138130, tdf#123621 sw: fix textbox position according to DOCX

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-11-25 17:13:03 UTC
it turned out the crash was reproducible only in libreoffice-7-0 branch but not in master, since it got fixed by https://git.libreoffice.org/core/commit/ee6cd34eb3a2bd1f1340063ee4b90a72ff0c9532 ( bug 123621 )
I've just backported it to libreoffice-7-0 branch.
Comment 7 Commit Notification 2020-11-25 22:09:05 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a45ea4f7939e7ca2e5c071ad209c957702b527e6

tdf#138130: sw_uiwriter: Add unittest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-11-25 23:26:49 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/7893e24c82c97de9c066f6e09df0ac107a6d97dd

tdf#138130: sw_uiwriter: Add unittest

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2020-11-26 09:07:12 UTC
Verified in

Version: 7.0.5.0.0+
Build ID: 7893e24c82c97de9c066f6e09df0ac107a6d97dd
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 10 Commit Notification 2020-12-01 09:21:35 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "libreoffice-7-0-4":

https://git.libreoffice.org/core/commit/296d814dcc72ecf15a443aed4d73106cef0672f1

tdf#138130, tdf#123621 sw: fix textbox position according to DOCX

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.