Bug 138134 - EDITING Validation circle does not disappear when value is changed by formula calculation
Summary: EDITING Validation circle does not disappear when value is changed by formula...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Tibor Nagy (NISZ)
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: Cell-Validity
  Show dependency treegraph
 
Reported: 2020-11-11 11:52 UTC by NISZ LibreOffice Team
Modified: 2021-02-08 11:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Calc (7.88 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-11-11 11:52 UTC, NISZ LibreOffice Team
Details
Example file from Calc saved as XLSX (5.21 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-11-11 11:52 UTC, NISZ LibreOffice Team
Details
Screenshot of the original documents side by side in Excel and Calc (49.35 KB, image/png)
2020-11-11 11:52 UTC, NISZ LibreOffice Team
Details
Screenshot of the modified documents side by side in Excel and Calc (47.74 KB, image/png)
2020-11-11 11:53 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-11-11 11:52:28 UTC
Created attachment 167195 [details]
Example file from Calc

Attached simple file contains a SUM formula in a cell summing two other cells content. It has a validity condition of Whole numbers > 6. Detective circles this since the formula result is 5.
When another value is entered in the summed cells, the formula updates the value, but the Detective circle is not removed, despite the new calculated value fulfilling the condition.

Steps to reproduce:
    1. Open attached file
    2. Notice the detective circle on C1
    3. Enter 4 in A1

Actual results:
Value in C1 becomes 7 but detective circle is still present. 
Note: Excel 2013 works the same way, but we can do better :).

Expected results:
Detective circle gone since the newly calculated value fulfills the validation condition.

LibreOffice details:
Version: 7.1.0.0.alpha1+ (x64)
Build ID: 00e5c63c35307faacf76a5e2ca7953c4208244ed
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2020-11-11 11:52:43 UTC
Created attachment 167196 [details]
Example file from Calc saved as XLSX
Comment 2 NISZ LibreOffice Team 2020-11-11 11:52:58 UTC
Created attachment 167197 [details]
Screenshot of the original documents side by side in Excel and Calc
Comment 3 NISZ LibreOffice Team 2020-11-11 11:53:14 UTC
Created attachment 167198 [details]
Screenshot of the modified documents side by side in Excel and Calc
Comment 4 Commit Notification 2021-01-08 11:36:55 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0478bdb68e8945cc76dc04c6f7040526656329a8

tdf#138134 sc: remove red circle of updated formula

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 NISZ LibreOffice Team 2021-02-08 11:39:11 UTC
Verified in
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 44b914b1e2616ca8f70e896e653a46ca93610234
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded